USN-2643-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-2643-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-2643-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-2643-2
Published
2015-06-21T18:47:11.238349Z
Modified
2015-06-21T18:47:11.238349Z
Summary
linux regression
Details

The Fix for CVE-2015-1328 introduced a regression into the Linux kernel's overlayfs file system. The removal of a directory that only exists on the lower layer results in a kernel panic.

We apologize for the inconvenience.

Original advisory details:

Philip Pettersson discovered a privilege escalation when using overlayfs mounts inside of user namespaces. A local user could exploit this flaw to gain administrative privileges on the system.

References

Affected packages

Ubuntu:14.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.13.0-55.94

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-3.13.0-55-generic": "3.13.0-55.94",
            "linux-image-3.13.0-55-powerpc-e500mc": "3.13.0-55.94",
            "linux-image-3.13.0-55-powerpc-smp": "3.13.0-55.94",
            "linux-image-3.13.0-55-lowlatency": "3.13.0-55.94",
            "linux-image-extra-3.13.0-55-generic": "3.13.0-55.94",
            "linux-image-3.13.0-55-powerpc-e500": "3.13.0-55.94",
            "linux-image-3.13.0-55-powerpc64-emb": "3.13.0-55.94",
            "linux-image-3.13.0-55-powerpc64-smp": "3.13.0-55.94",
            "linux-image-3.13.0-55-generic-lpae": "3.13.0-55.94"
        }
    ]
}