USN-3135-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3135-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3135-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3135-2
Published
2016-11-28T13:21:46.300913Z
Modified
2016-11-28T13:21:46.300913Z
Summary
gst-plugins-good0.10, gst-plugins-good1.0 vulnerability
Details

USN-3135-1 fixed a vulnerability in GStreamer Good Plugins. The original security fix was incomplete. This update fixes the problem.

Original advisory details:

Chris Evans discovered that GStreamer Good Plugins did not correctly handle malformed FLC movie files. If a user were tricked into opening a crafted FLC movie file with a GStreamer application, an attacker could cause a denial of service via application crash, or execute arbitrary code with the privileges of the user invoking the program.

References

Affected packages

Ubuntu:14.04:LTS / gst-plugins-good0.10

Package

Name
gst-plugins-good0.10

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.10.31-3+nmu1ubuntu5.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gstreamer0.10-plugins-good": "0.10.31-3+nmu1ubuntu5.2",
            "gstreamer0.10-plugins-good-doc": "0.10.31-3+nmu1ubuntu5.2",
            "gstreamer0.10-pulseaudio": "0.10.31-3+nmu1ubuntu5.2",
            "gstreamer0.10-gconf": "0.10.31-3+nmu1ubuntu5.2"
        }
    ]
}

Ubuntu:14.04:LTS / gst-plugins-good1.0

Package

Name
gst-plugins-good1.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.4-1~ubuntu1.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgstreamer-plugins-good1.0-dev": "1.2.4-1~ubuntu1.3",
            "libgstreamer-plugins-good1.0-0": "1.2.4-1~ubuntu1.3",
            "gstreamer1.0-pulseaudio": "1.2.4-1~ubuntu1.3",
            "gstreamer1.0-plugins-good-doc": "1.2.4-1~ubuntu1.3",
            "gstreamer1.0-plugins-good": "1.2.4-1~ubuntu1.3"
        }
    ]
}

Ubuntu:16.04:LTS / gst-plugins-good1.0

Package

Name
gst-plugins-good1.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.8.2-1ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgstreamer-plugins-good1.0-0": "1.8.2-1ubuntu0.3",
            "libgstreamer-plugins-good1.0-dev": "1.8.2-1ubuntu0.3",
            "gstreamer1.0-pulseaudio": "1.8.2-1ubuntu0.3",
            "gstreamer1.0-plugins-good-doc": "1.8.2-1ubuntu0.3",
            "gstreamer1.0-plugins-good": "1.8.2-1ubuntu0.3"
        }
    ]
}