USN-3256-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3256-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3256-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3256-1
Related
  • CVE-2017-7308
Published
2017-04-05T03:38:55.257501Z
Modified
2017-04-05T03:38:55.257501Z
Summary
linux, linux-aws, linux-gke, linux-raspi2, linux-snapdragon, linux-ti-omap4 vulnerability
Details

Andrey Konovalov discovered that the AF_PACKET implementation in the Linux kernel did not properly validate certain block-size data. A local attacker could use this to cause a denial of service (system crash).

References

Affected packages

Ubuntu:14.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.13.0-116.163

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-3.13.0-116-lowlatency": "3.13.0-116.163",
            "linux-image-3.13.0-116-powerpc-e500mc": "3.13.0-116.163",
            "linux-image-3.13.0-116-powerpc-smp": "3.13.0-116.163",
            "linux-image-3.13.0-116-generic-lpae": "3.13.0-116.163",
            "linux-image-3.13.0-116-powerpc64-emb": "3.13.0-116.163",
            "linux-image-3.13.0-116-powerpc64-smp": "3.13.0-116.163",
            "linux-image-3.13.0-116-powerpc-e500": "3.13.0-116.163",
            "linux-image-extra-3.13.0-116-generic": "3.13.0-116.163",
            "linux-image-3.13.0-116-generic": "3.13.0-116.163"
        }
    ]
}

Ubuntu:16.04:LTS / linux-raspi2

Package

Name
linux-raspi2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1052.59

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-1052-raspi2": "4.4.0-1052.59"
        }
    ]
}

Ubuntu:16.04:LTS / linux-gke

Package

Name
linux-gke

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1010.10

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-1010-gke": "4.4.0-1010.10",
            "linux-image-extra-4.4.0-1010-gke": "4.4.0-1010.10"
        }
    ]
}

Ubuntu:16.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1013.22

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-1013-aws": "4.4.0-1013.22"
        }
    ]
}

Ubuntu:16.04:LTS / linux-snapdragon

Package

Name
linux-snapdragon

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1055.59

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-1055-snapdragon": "4.4.0-1055.59"
        }
    ]
}

Ubuntu:16.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-72.93

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-extra-4.4.0-72-generic": "4.4.0-72.93",
            "linux-image-4.4.0-72-powerpc64-emb": "4.4.0-72.93",
            "linux-image-4.4.0-72-lowlatency": "4.4.0-72.93",
            "linux-image-4.4.0-72-powerpc64-smp": "4.4.0-72.93",
            "linux-image-4.4.0-72-powerpc-smp": "4.4.0-72.93",
            "linux-image-4.4.0-72-powerpc-e500mc": "4.4.0-72.93",
            "linux-image-4.4.0-72-generic": "4.4.0-72.93",
            "linux-image-4.4.0-72-generic-lpae": "4.4.0-72.93"
        }
    ]
}