USN-3298-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3298-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3298-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3298-1
Related
Published
2017-05-24T11:37:13.252830Z
Modified
2017-05-24T11:37:13.252830Z
Summary
miniupnpc vulnerability
Details

It was discovered that MiniUPnP incorrectly handled memory. A remote attacker could use this issue to cause a denial of service or possibly execute arbitrary code with privileges of the user running an application that uses the MiniUPnP library.

References

Affected packages

Ubuntu:14.04:LTS / miniupnpc

Package

Name
miniupnpc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6-3ubuntu2.14.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libminiupnpc8": "1.6-3ubuntu2.14.04.3",
            "libminiupnpc-dev": "1.6-3ubuntu2.14.04.3",
            "miniupnpc": "1.6-3ubuntu2.14.04.3"
        }
    ]
}

Ubuntu:16.04:LTS / miniupnpc

Package

Name
miniupnpc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.9.20140610-2ubuntu2.16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libminiupnpc10": "1.9.20140610-2ubuntu2.16.04.1",
            "libminiupnpc-dev": "1.9.20140610-2ubuntu2.16.04.1",
            "python-miniupnpc": "1.9.20140610-2ubuntu2.16.04.1",
            "miniupnpc": "1.9.20140610-2ubuntu2.16.04.1"
        }
    ]
}