USN-3385-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3385-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3385-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3385-1
Related
Published
2017-08-11T02:47:29.954164Z
Modified
2017-08-11T02:47:29.954164Z
Summary
linux, linux-aws, linux-gke, linux-raspi2, linux-snapdragon vulnerabilities
Details

Andrey Konovalov discovered a race condition in the UDP Fragmentation Offload (UFO) code in the Linux kernel. A local attacker could use this to cause a denial of service or execute arbitrary code. (CVE-2017-1000112)

Andrey Konovalov discovered a race condition in AF_PACKET socket option handling code in the Linux kernel. A local unprivileged attacker could use this to cause a denial of service or possibly execute arbitrary code. (CVE-2017-1000111)

References

Affected packages

Ubuntu:16.04:LTS / linux-raspi2

Package

Name
linux-raspi2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1069.77

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-1069-raspi2": "4.4.0-1069.77"
        }
    ]
}

Ubuntu:16.04:LTS / linux-gke

Package

Name
linux-gke

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1026.26

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-1026-gke": "4.4.0-1026.26",
            "linux-image-extra-4.4.0-1026-gke": "4.4.0-1026.26"
        }
    ]
}

Ubuntu:16.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1030.39

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-1030-aws": "4.4.0-1030.39"
        }
    ]
}

Ubuntu:16.04:LTS / linux-snapdragon

Package

Name
linux-snapdragon

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1071.76

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-1071-snapdragon": "4.4.0-1071.76"
        }
    ]
}

Ubuntu:16.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-91.114

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.4.0-91-generic": "4.4.0-91.114",
            "linux-image-4.4.0-91-lowlatency": "4.4.0-91.114",
            "linux-image-4.4.0-91-generic-lpae": "4.4.0-91.114",
            "linux-image-4.4.0-91-powerpc64-emb": "4.4.0-91.114",
            "linux-image-extra-4.4.0-91-generic": "4.4.0-91.114",
            "linux-image-4.4.0-91-powerpc-smp": "4.4.0-91.114",
            "linux-image-4.4.0-91-powerpc64-smp": "4.4.0-91.114",
            "linux-image-4.4.0-91-powerpc-e500mc": "4.4.0-91.114"
        }
    ]
}