USN-3454-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3454-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3454-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3454-1
Related
Published
2017-10-12T18:08:32.601053Z
Modified
2017-10-12T18:08:32.601053Z
Summary
libffi vulnerability
Details

It was discovered that libffi incorrectly enforced an executable stack. An attacker could possibly use this issue, in combination with another vulnerability, to facilitate executing arbitrary code.

References

Affected packages

Ubuntu:14.04:LTS / libffi

Package

Name
libffi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1~rc1+r3.0.13-12ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libffi-dev": "3.1~rc1+r3.0.13-12ubuntu0.2",
            "libffi6": "3.1~rc1+r3.0.13-12ubuntu0.2",
            "libffi6-udeb": "3.1~rc1+r3.0.13-12ubuntu0.2"
        }
    ]
}