USN-3616-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3616-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3616-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3616-1
Related
Published
2018-04-03T16:53:52.561976Z
Modified
2018-04-03T16:53:52.561976Z
Summary
python-crypto vulnerability
Details

It was discovered that Python Crypto incorrectly generated ElGamal key parameters. A remote attacker could possibly use this issue to obtain sensitive information.

References

Affected packages

Ubuntu:14.04:LTS / python-crypto

Package

Name
python-crypto

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.1-4ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-crypto": "2.6.1-4ubuntu0.3",
            "python-crypto-doc": "2.6.1-4ubuntu0.3",
            "python3-crypto": "2.6.1-4ubuntu0.3"
        }
    ]
}

Ubuntu:16.04:LTS / python-crypto

Package

Name
python-crypto

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.1-6ubuntu0.16.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-crypto": "2.6.1-6ubuntu0.16.04.3",
            "python-crypto-doc": "2.6.1-6ubuntu0.16.04.3",
            "python3-crypto": "2.6.1-6ubuntu0.16.04.3"
        }
    ]
}