USN-3658-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3658-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3658-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3658-1
Related
Published
2018-05-23T14:38:30.600877Z
Modified
2018-05-23T14:38:30.600877Z
Summary
procps vulnerabilities
Details

It was discovered that the procps-ng top utility incorrectly read its configuration file from the current working directory. A local attacker could possibly use this issue to escalate privileges. (CVE-2018-1122)

It was discovered that the procps-ng ps tool incorrectly handled memory. A local user could possibly use this issue to cause a denial of service. (CVE-2018-1123)

It was discovered that libprocps incorrectly handled the file2strvec() function. A local attacker could possibly use this to execute arbitrary code. (CVE-2018-1124)

It was discovered that the procps-ng pgrep utility incorrectly handled memory. A local attacker could possibly use this issue to cause de denial of service. (CVE-2018-1125)

It was discovered that procps-ng incorrectly handled memory. A local attacker could use this issue to cause a denial of service, or possibly execute arbitrary code. (CVE-2018-1126)

References

Affected packages

Ubuntu:18.04:LTS / procps

Package

Name
procps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.3.12-3ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libprocps-dev": "2:3.3.12-3ubuntu1.1",
            "libprocps6": "2:3.3.12-3ubuntu1.1",
            "procps": "2:3.3.12-3ubuntu1.1"
        }
    ]
}

Ubuntu:14.04:LTS / procps

Package

Name
procps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:3.3.9-1ubuntu2.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libprocps3": "1:3.3.9-1ubuntu2.3",
            "procps": "1:3.3.9-1ubuntu2.3",
            "libprocps3-dev": "1:3.3.9-1ubuntu2.3"
        }
    ]
}

Ubuntu:16.04:LTS / procps

Package

Name
procps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:3.3.10-4ubuntu2.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libprocps4-dev": "2:3.3.10-4ubuntu2.4",
            "procps": "2:3.3.10-4ubuntu2.4",
            "libprocps4": "2:3.3.10-4ubuntu2.4"
        }
    ]
}