USN-3817-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3817-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3817-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3817-1
Related
Published
2018-11-13T15:40:04.128236Z
Modified
2018-11-13T15:40:04.128236Z
Summary
python2.7, python3.4, python3.5 vulnerabilities
Details

It was discovered that Python incorrectly handled large amounts of data. A remote attacker could use this issue to cause Python to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2018-1000030)

It was discovered that Python incorrectly handled running external commands in the shutil module. A remote attacker could use this issue to cause Python to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2018-1000802)

It was discovered that Python incorrectly used regular expressions vulnerable to catastrophic backtracking. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2018-1060, CVE-2018-1061)

It was discovered that Python failed to initialize Expat's hash salt. A remote attacker could possibly use this issue to cause hash collisions, leading to a denial of service. (CVE-2018-14647)

References

Affected packages

Ubuntu:14.04:LTS / python3.4

Package

Name
python3.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.4.3-1ubuntu1~14.04.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3.4": "3.4.3-1ubuntu1~14.04.7",
            "libpython3.4-dev": "3.4.3-1ubuntu1~14.04.7",
            "libpython3.4-testsuite": "3.4.3-1ubuntu1~14.04.7",
            "python3.4-doc": "3.4.3-1ubuntu1~14.04.7",
            "python3.4-minimal": "3.4.3-1ubuntu1~14.04.7",
            "python3.4-venv": "3.4.3-1ubuntu1~14.04.7",
            "libpython3.4-stdlib": "3.4.3-1ubuntu1~14.04.7",
            "idle-python3.4": "3.4.3-1ubuntu1~14.04.7",
            "python3.4-examples": "3.4.3-1ubuntu1~14.04.7",
            "python3.4-dev": "3.4.3-1ubuntu1~14.04.7",
            "libpython3.4-minimal": "3.4.3-1ubuntu1~14.04.7",
            "libpython3.4": "3.4.3-1ubuntu1~14.04.7"
        }
    ]
}

Ubuntu:14.04:LTS / python2.7

Package

Name
python2.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7.6-8ubuntu0.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python2.7": "2.7.6-8ubuntu0.5",
            "libpython2.7": "2.7.6-8ubuntu0.5",
            "libpython2.7-stdlib": "2.7.6-8ubuntu0.5",
            "python2.7-dev": "2.7.6-8ubuntu0.5",
            "python2.7-examples": "2.7.6-8ubuntu0.5",
            "python2.7-doc": "2.7.6-8ubuntu0.5",
            "idle-python2.7": "2.7.6-8ubuntu0.5",
            "libpython2.7-testsuite": "2.7.6-8ubuntu0.5",
            "python2.7-minimal": "2.7.6-8ubuntu0.5",
            "libpython2.7-dev": "2.7.6-8ubuntu0.5",
            "libpython2.7-minimal": "2.7.6-8ubuntu0.5"
        }
    ]
}

Ubuntu:18.04:LTS / python2.7

Package

Name
python2.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7.15~rc1-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python2.7": "2.7.15~rc1-1ubuntu0.1",
            "libpython2.7": "2.7.15~rc1-1ubuntu0.1",
            "libpython2.7-stdlib": "2.7.15~rc1-1ubuntu0.1",
            "python2.7-dev": "2.7.15~rc1-1ubuntu0.1",
            "python2.7-examples": "2.7.15~rc1-1ubuntu0.1",
            "python2.7-doc": "2.7.15~rc1-1ubuntu0.1",
            "idle-python2.7": "2.7.15~rc1-1ubuntu0.1",
            "python2.7-minimal": "2.7.15~rc1-1ubuntu0.1",
            "libpython2.7-testsuite": "2.7.15~rc1-1ubuntu0.1",
            "libpython2.7-dev": "2.7.15~rc1-1ubuntu0.1",
            "libpython2.7-minimal": "2.7.15~rc1-1ubuntu0.1"
        }
    ]
}

Ubuntu:16.04:LTS / python3.5

Package

Name
python3.5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.2-2ubuntu0~16.04.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3.5-venv": "3.5.2-2ubuntu0~16.04.5",
            "python3.5-minimal": "3.5.2-2ubuntu0~16.04.5",
            "python3.5-dev": "3.5.2-2ubuntu0~16.04.5",
            "idle-python3.5": "3.5.2-2ubuntu0~16.04.5",
            "libpython3.5": "3.5.2-2ubuntu0~16.04.5",
            "python3.5-examples": "3.5.2-2ubuntu0~16.04.5",
            "python3.5": "3.5.2-2ubuntu0~16.04.5",
            "libpython3.5-dev": "3.5.2-2ubuntu0~16.04.5",
            "libpython3.5-minimal": "3.5.2-2ubuntu0~16.04.5",
            "python3.5-doc": "3.5.2-2ubuntu0~16.04.5",
            "libpython3.5-stdlib": "3.5.2-2ubuntu0~16.04.5",
            "libpython3.5-testsuite": "3.5.2-2ubuntu0~16.04.5"
        }
    ]
}

Ubuntu:16.04:LTS / python2.7

Package

Name
python2.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7.12-1ubuntu0~16.04.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python2.7": "2.7.12-1ubuntu0~16.04.4",
            "libpython2.7": "2.7.12-1ubuntu0~16.04.4",
            "libpython2.7-stdlib": "2.7.12-1ubuntu0~16.04.4",
            "python2.7-dev": "2.7.12-1ubuntu0~16.04.4",
            "python2.7-examples": "2.7.12-1ubuntu0~16.04.4",
            "python2.7-doc": "2.7.12-1ubuntu0~16.04.4",
            "idle-python2.7": "2.7.12-1ubuntu0~16.04.4",
            "libpython2.7-testsuite": "2.7.12-1ubuntu0~16.04.4",
            "python2.7-minimal": "2.7.12-1ubuntu0~16.04.4",
            "libpython2.7-dev": "2.7.12-1ubuntu0~16.04.4",
            "libpython2.7-minimal": "2.7.12-1ubuntu0~16.04.4"
        }
    ]
}