USN-3929-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3929-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3929-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3929-1
Related
  • CVE-2014-9323
  • CVE-2017-6369
Published
2019-04-02T14:36:46.964566Z
Modified
2019-04-02T14:36:46.964566Z
Summary
firebird2.5 vulnerabilities
Details

It was discovered that Firebird incorrectly handled certain malformed packets. A remote attacker could possibly use this issue with a specially crafted network packet to cause Firebird to crash, resulting in a denial of service. (CVE-2014-9323)

It was discovered that Firebird incorrectly handled certain UDF libraries. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2017-6369)

References

Affected packages

Ubuntu:14.04:LTS / firebird2.5

Package

Name
firebird2.5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.5.2.26540.ds4-9ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "firebird2.5-doc": "2.5.2.26540.ds4-9ubuntu1.1",
            "firebird2.5-examples": "2.5.2.26540.ds4-9ubuntu1.1",
            "firebird-dev": "2.5.2.26540.ds4-9ubuntu1.1",
            "firebird2.5-server-common": "2.5.2.26540.ds4-9ubuntu1.1",
            "firebird2.5-common": "2.5.2.26540.ds4-9ubuntu1.1",
            "firebird2.5-classic": "2.5.2.26540.ds4-9ubuntu1.1",
            "firebird2.5-common-doc": "2.5.2.26540.ds4-9ubuntu1.1",
            "firebird2.5-classic-common": "2.5.2.26540.ds4-9ubuntu1.1",
            "libfbclient2": "2.5.2.26540.ds4-9ubuntu1.1",
            "firebird2.5-superclassic": "2.5.2.26540.ds4-9ubuntu1.1",
            "libib-util": "2.5.2.26540.ds4-9ubuntu1.1",
            "firebird2.5-super": "2.5.2.26540.ds4-9ubuntu1.1",
            "libfbembed2.5": "2.5.2.26540.ds4-9ubuntu1.1"
        }
    ]
}