USN-4038-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4038-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4038-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4038-1
Related
Published
2019-06-26T12:01:55.434655Z
Modified
2019-06-26T12:01:55.434655Z
Summary
bzip2 vulnerabilities
Details

Aladdin Mubaied discovered that bzip2 incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-3189)

It was discovered that bzip2 incorrectly handled certain files. An attacker could possibly use this issue to execute arbitrary code. (CVE-2019-12900)

References

Affected packages

Ubuntu:18.04:LTS / bzip2

Package

Name
bzip2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.6-8.1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libbz2-1.0": "1.0.6-8.1ubuntu0.1",
            "bzip2": "1.0.6-8.1ubuntu0.1",
            "libbz2-dev": "1.0.6-8.1ubuntu0.1",
            "bzip2-doc": "1.0.6-8.1ubuntu0.1"
        }
    ]
}

Ubuntu:16.04:LTS / bzip2

Package

Name
bzip2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.6-8ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libbz2-1.0": "1.0.6-8ubuntu0.1",
            "bzip2": "1.0.6-8ubuntu0.1",
            "libbz2-dev": "1.0.6-8ubuntu0.1",
            "bzip2-doc": "1.0.6-8ubuntu0.1"
        }
    ]
}