USN-4212-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4212-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4212-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4212-1
Related
Published
2019-12-04T12:48:05.831628Z
Modified
2019-12-04T12:48:05.831628Z
Summary
haproxy vulnerability
Details

Tim Düsterhus discovered that HAProxy incorrectly handled certain HTTP/2 headers. An attacker could possibly use this issue to execute arbitrary code through CRLF injection.

References

Affected packages

Ubuntu:18.04:LTS / haproxy

Package

Name
haproxy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.8.8-1ubuntu0.9

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "haproxy": "1.8.8-1ubuntu0.9",
            "haproxy-doc": "1.8.8-1ubuntu0.9",
            "vim-haproxy": "1.8.8-1ubuntu0.9"
        }
    ]
}