USN-4214-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4214-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4214-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4214-2
Related
Published
2019-12-11T16:53:39.008079Z
Modified
2019-12-11T16:53:39.008079Z
Summary
librabbitmq vulnerability
Details

USN-4214-1 fixed a vulnerability in RabbitMQ. This update provides the corresponding updates for Ubuntu 16.04 LTS and Ubuntu 18.04 LTS.

Original advisory details:

It was discovered that RabbitMQ incorrectly handled certain inputs. An attacker could possibly use this issue to execute arbitrary code.

References

Affected packages

Ubuntu:18.04:LTS / librabbitmq

Package

Name
librabbitmq

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.8.0-1ubuntu0.18.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "librabbitmq-dev": "0.8.0-1ubuntu0.18.04.2",
            "librabbitmq4": "0.8.0-1ubuntu0.18.04.2",
            "amqp-tools": "0.8.0-1ubuntu0.18.04.2"
        }
    ]
}

Ubuntu:16.04:LTS / librabbitmq

Package

Name
librabbitmq

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.1-1ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "librabbitmq-dev": "0.7.1-1ubuntu0.2",
            "librabbitmq4": "0.7.1-1ubuntu0.2",
            "amqp-tools": "0.7.1-1ubuntu0.2"
        }
    ]
}