USN-4253-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4253-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4253-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4253-2
Related
  • CVE-2019-14615
Published
2020-01-28T23:38:43.479353Z
Modified
2020-01-28T23:38:43.479353Z
Summary
linux-hwe vulnerability
Details

USN-4253-1 fixed vulnerabilities in the Linux kernel for Ubuntu 19.10. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 19.10 for Ubuntu 18.04 LTS.

It was discovered that the Linux kernel did not properly clear data structures on context switches for certain Intel graphics processors. A local attacker could use this to expose sensitive information.

References

Affected packages

Ubuntu:18.04:LTS / linux-hwe

Package

Name
linux-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-28.30~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-snapdragon-hwe-18.04": "5.3.0.28.96",
            "linux-image-5.3.0-28-generic-lpae": "5.3.0-28.30~18.04.1",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.3.0.28.96",
            "linux-image-snapdragon-hwe-18.04-edge": "5.3.0.28.96",
            "linux-image-lowlatency-hwe-18.04": "5.3.0.28.96",
            "linux-image-virtual-hwe-18.04-edge": "5.3.0.28.96",
            "linux-image-5.3.0-28-generic": "5.3.0-28.30~18.04.1",
            "linux-image-generic-hwe-18.04": "5.3.0.28.96",
            "linux-image-lowlatency-hwe-18.04-edge": "5.3.0.28.96",
            "linux-image-virtual-hwe-18.04": "5.3.0.28.96",
            "linux-image-generic-hwe-18.04-edge": "5.3.0.28.96",
            "linux-image-5.3.0-28-lowlatency": "5.3.0-28.30~18.04.1",
            "linux-image-generic-lpae-hwe-18.04": "5.3.0.28.96"
        }
    ]
}