USN-4344-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4344-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4344-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4344-1
Related
Published
2020-04-28T23:46:22.799707Z
Modified
2020-04-28T23:46:22.799707Z
Summary
linux-gke-5.0, linux-oem-osp11 vulnerabilities
Details

It was discovered that the Intel Wi-Fi driver in the Linux kernel did not properly check for errors in some situations. A local attacker could possibly use this to cause a denial of service (system crash). (CVE-2019-16234)

It was discovered that the Intel WiMAX 2400 driver in the Linux kernel did not properly deallocate memory in certain situations. A local attacker could use this to cause a denial of service (kernel memory exhaustion). (CVE-2019-19051)

Tristan Madani discovered that the block I/O tracing implementation in the Linux kernel contained a race condition. A local attacker could use this to cause a denial of service (system crash) or possibly expose sensitive information. (CVE-2019-19768)

It was discovered that the vhost net driver in the Linux kernel contained a stack buffer overflow. A local attacker with the ability to perform ioctl() calls on /dev/vhost-net could use this to cause a denial of service (system crash). (CVE-2020-10942)

It was discovered that the virtual terminal implementation in the Linux kernel contained a race condition. A local attacker could possibly use this to cause a denial of service (system crash) or expose sensitive information. (CVE-2020-8648)

Shijie Luo discovered that the ext4 file system implementation in the Linux kernel did not properly check for a too-large journal size. An attacker could use this to construct a malicious ext4 image that, when mounted, could cause a denial of service (soft lockup). (CVE-2020-8992)

Jordy Zomer discovered that the floppy driver in the Linux kernel did not properly check for errors in some situations. A local attacker could possibly use this to cause a denial of service (system crash) or possibly expose sensitive information. (CVE-2020-9383)

References

Affected packages

Ubuntu:18.04:LTS / linux-oem-osp1

Package

Name
linux-oem-osp1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.0.0-1050.55

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-oem-osp1": "5.0.0.1050.53",
            "linux-image-5.0.0-1050-oem-osp1": "5.0.0-1050.55"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gke-5.0

Package

Name
linux-gke-5.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.0.0-1035.36

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.0.0-1035-gke": "5.0.0-1035.36",
            "linux-image-gke-5.0": "5.0.0.1035.23"
        }
    ]
}