USN-4430-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4430-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4430-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4430-1
Related
Published
2020-07-22T13:13:38.303968Z
Modified
2020-07-22T13:13:38.303968Z
Summary
pillow vulnerabilities
Details

It was discovered that Pillow incorrectly handled certain image files. If a user or automated system were tricked into opening a specially-crafted image file, a remote attacker could possibly cause Pillow to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:18.04:LTS / pillow

Package

Name
pillow

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.1.0-1ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-pil.imagetk": "5.1.0-1ubuntu0.3",
            "python-pil-doc": "5.1.0-1ubuntu0.3",
            "python3-pil": "5.1.0-1ubuntu0.3",
            "python-pil.imagetk": "5.1.0-1ubuntu0.3",
            "python-pil": "5.1.0-1ubuntu0.3"
        }
    ]
}

Ubuntu:16.04:LTS / pillow

Package

Name
pillow

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1.2-0ubuntu1.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-pil.imagetk": "3.1.2-0ubuntu1.4",
            "python-pil-doc": "3.1.2-0ubuntu1.4",
            "python3-pil": "3.1.2-0ubuntu1.4",
            "python-pil.imagetk": "3.1.2-0ubuntu1.4",
            "python-imaging": "3.1.2-0ubuntu1.4",
            "python-pil": "3.1.2-0ubuntu1.4"
        }
    ]
}