USN-4586-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4586-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4586-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4586-2
Related
  • CVE-2019-11037
Published
2022-01-24T20:54:51.924966Z
Modified
2022-01-24T20:54:51.924966Z
Summary
php-imagick vulnerability
Details

USN-4586-1 fixed vulnerabilities in PHP ImageMagick. This update provides the corresponding update for Ubuntu 16.04 ESM.

Original advisory details:

It was discovered that PHP ImageMagick extension didn't check the address used by an array. An attacker could use this issue to cause PHP ImageMagick to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:Pro:16.04:LTS / php-imagick

Package

Name
php-imagick

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.4.0~rc6-1ubuntu3+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "php-imagick": "3.4.0~rc6-1ubuntu3+esm1"
        }
    ]
}