USN-4787-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4787-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4787-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4787-1
Related
Published
2021-03-15T21:05:44.974241Z
Modified
2021-03-15T21:05:44.974241Z
Summary
jq vulnerability
Details

It was discovered that jq did not perform sufficient bounds checking, resulting in unbounded resource consumption. An attacker could use this vulnerability to cause a denial of service.

References

Affected packages

Ubuntu:Pro:14.04:LTS / jq

Package

Name
jq

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.3-1.1ubuntu1.1+esm3

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "jq": "1.3-1.1ubuntu1.1+esm3"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / jq

Package

Name
jq

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5+dfsg-1ubuntu0.1+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "jq": "1.5+dfsg-1ubuntu0.1+esm2"
        }
    ]
}