USN-4840-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4840-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4840-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4840-1
Related
Published
2021-03-15T22:22:57.996020Z
Modified
2021-03-15T22:22:57.996020Z
Summary
singularity-container vulnerabilities
Details

It was discovered that Singularity incorrectly handled certain inputs. An attacker could possibly use this issue to obtain sensitive information. (CVE-2018-19295)

It was discovered that Singularity incorrectly handled access control. An attacker could possibly use this issue to obtain sensitive information. (CVE-2018-12021)

References

Affected packages

Ubuntu:Pro:18.04:LTS / singularity-container

Package

Name
singularity-container

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.2-4ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "singularity-container": "2.4.2-4ubuntu0.1~esm1"
        }
    ]
}