USN-4921-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4921-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4921-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4921-1
Related
Published
2021-04-20T15:41:45.110722Z
Modified
2021-04-20T15:41:45.110722Z
Summary
libcaca vulnerability
Details

It was discovered that libcaca incorrectly handled certain images. An attacker could possibly use this issue to execute arbitrary code.

References

Affected packages

Ubuntu:20.04:LTS / libcaca

Package

Name
libcaca

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.99.beta19-2.1ubuntu1.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcaca-dev": "0.99.beta19-2.1ubuntu1.20.04.1",
            "caca-utils": "0.99.beta19-2.1ubuntu1.20.04.1",
            "libcaca0": "0.99.beta19-2.1ubuntu1.20.04.1"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / libcaca

Package

Name
libcaca

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.99.beta18-1ubuntu5.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libcaca-dev": "0.99.beta18-1ubuntu5.1+esm1",
            "caca-utils": "0.99.beta18-1ubuntu5.1+esm1",
            "libcaca0": "0.99.beta18-1ubuntu5.1+esm1"
        }
    ]
}

Ubuntu:18.04:LTS / libcaca

Package

Name
libcaca

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.99.beta19-2ubuntu0.18.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcaca-dev": "0.99.beta19-2ubuntu0.18.04.2",
            "caca-utils": "0.99.beta19-2ubuntu0.18.04.2",
            "libcaca0": "0.99.beta19-2ubuntu0.18.04.2"
        }
    ]
}

Ubuntu:16.04:LTS / libcaca

Package

Name
libcaca

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.99.beta19-2ubuntu0.16.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcaca-dev": "0.99.beta19-2ubuntu0.16.04.2",
            "caca-utils": "0.99.beta19-2ubuntu0.16.04.2",
            "libcaca0": "0.99.beta19-2ubuntu0.16.04.2"
        }
    ]
}