USN-4937-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4937-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4937-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4937-1
Related
Published
2021-05-06T11:15:45.090297Z
Modified
2021-05-06T11:15:45.090297Z
Summary
gnome-autoar vulnerability
Details

Ondrej Holy discovered that GNOME Autoar could extract files outside of the intended directory. If a user were tricked into extracting a specially crafted archive, a remote attacker could create files in arbitrary locations, possibly leading to code execution.

References

Affected packages

Ubuntu:18.04:LTS / gnome-autoar

Package

Name
gnome-autoar

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.2.3-1ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgnome-autoar-gtk-0-dev": "0.2.3-1ubuntu0.3",
            "libgnome-autoar-0-dev": "0.2.3-1ubuntu0.3",
            "gir1.2-gnomeautoargtk-0.1": "0.2.3-1ubuntu0.3",
            "libgnome-autoar-gtk-0-0": "0.2.3-1ubuntu0.3",
            "libgnome-autoar-doc": "0.2.3-1ubuntu0.3",
            "gir1.2-gnomeautoar-0.1": "0.2.3-1ubuntu0.3",
            "libgnome-autoar-0-0": "0.2.3-1ubuntu0.3"
        }
    ]
}

Ubuntu:20.04:LTS / gnome-autoar

Package

Name
gnome-autoar

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.2.3-2ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgnome-autoar-gtk-0-dev": "0.2.3-2ubuntu0.3",
            "libgnome-autoar-0-dev": "0.2.3-2ubuntu0.3",
            "gir1.2-gnomeautoargtk-0.1": "0.2.3-2ubuntu0.3",
            "libgnome-autoar-gtk-0-0": "0.2.3-2ubuntu0.3",
            "libgnome-autoar-doc": "0.2.3-2ubuntu0.3",
            "gir1.2-gnomeautoar-0.1": "0.2.3-2ubuntu0.3",
            "libgnome-autoar-0-0": "0.2.3-2ubuntu0.3"
        }
    ]
}