USN-5038-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5038-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5038-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5038-1
Related
Published
2021-08-12T17:19:56.940812Z
Modified
2021-08-12T17:19:56.940812Z
Summary
postgresql-10, postgresql-12, postgresql-13 vulnerabilities
Details

It was discovered that the PostgresQL planner could create incorrect plans in certain circumstances. A remote attacker could use this issue to cause PostgreSQL to crash, resulting in a denial of service, or possibly obtain sensitive information from memory. This issue only affected Ubuntu 20.04 LTS and Ubuntu 21.04. (CVE-2021-3677)

It was discovered that PostgreSQL incorrectly handled certain SSL renegotiation ClientHello messages from clients. A remote attacker could possibly use this issue to cause PostgreSQL to crash, resulting in a denial of service. (CVE-2021-3449)

References

Affected packages

Ubuntu:20.04:LTS / postgresql-12

Package

Name
postgresql-12

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
12.8-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpq-dev": "12.8-0ubuntu0.20.04.1",
            "libecpg6": "12.8-0ubuntu0.20.04.1",
            "postgresql-plpython3-12": "12.8-0ubuntu0.20.04.1",
            "postgresql-doc-12": "12.8-0ubuntu0.20.04.1",
            "libpgtypes3": "12.8-0ubuntu0.20.04.1",
            "postgresql-pltcl-12": "12.8-0ubuntu0.20.04.1",
            "libecpg-dev": "12.8-0ubuntu0.20.04.1",
            "postgresql-plperl-12": "12.8-0ubuntu0.20.04.1",
            "postgresql-server-dev-12": "12.8-0ubuntu0.20.04.1",
            "postgresql-12": "12.8-0ubuntu0.20.04.1",
            "postgresql-client-12": "12.8-0ubuntu0.20.04.1",
            "libpq5": "12.8-0ubuntu0.20.04.1",
            "libecpg-compat3": "12.8-0ubuntu0.20.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / postgresql-10

Package

Name
postgresql-10

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.18-0ubuntu0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libecpg6": "10.18-0ubuntu0.18.04.1",
            "libecpg-dev": "10.18-0ubuntu0.18.04.1",
            "postgresql-plperl-10": "10.18-0ubuntu0.18.04.1",
            "libpq5": "10.18-0ubuntu0.18.04.1",
            "postgresql-client-10": "10.18-0ubuntu0.18.04.1",
            "libpq-dev": "10.18-0ubuntu0.18.04.1",
            "libpgtypes3": "10.18-0ubuntu0.18.04.1",
            "postgresql-10": "10.18-0ubuntu0.18.04.1",
            "postgresql-doc-10": "10.18-0ubuntu0.18.04.1",
            "postgresql-plpython-10": "10.18-0ubuntu0.18.04.1",
            "libecpg-compat3": "10.18-0ubuntu0.18.04.1",
            "postgresql-server-dev-10": "10.18-0ubuntu0.18.04.1",
            "postgresql-pltcl-10": "10.18-0ubuntu0.18.04.1",
            "postgresql-plpython3-10": "10.18-0ubuntu0.18.04.1"
        }
    ]
}