USN-5068-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5068-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5068-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5068-1
Related
Published
2021-09-08T13:08:35.581506Z
Modified
2021-09-08T13:08:35.581506Z
Summary
libgd2 vulnerabilities
Details

It was discovered that GD Graphics Library incorrectly handled certain GD and GD2 files. An attacker could possibly use this issue to cause a crash or expose sensitive information. This issue only affected Ubuntu 20.04 LTS, Ubuntu 18.04 LTS, Ubuntu 16.04 ESM, and Ubuntu 14.04 ESM. (CVE-2017-6363)

It was discovered that GD Graphics Library incorrectly handled certain TGA files. An attacker could possibly use this issue to cause a denial of service or expose sensitive information. (CVE-2021-381)

It was discovered that GD Graphics Library incorrectly handled certain files. An attacker could possibly use this issue to cause a crash. (CVE-2021-40145)

References

Affected packages

Ubuntu:20.04:LTS / libgd2

Package

Name
libgd2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.5-5.2ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgd-dev": "2.2.5-5.2ubuntu2.1",
            "libgd-tools": "2.2.5-5.2ubuntu2.1",
            "libgd3": "2.2.5-5.2ubuntu2.1"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / libgd2

Package

Name
libgd2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.0-3ubuntu0.11+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libgd2-xpm-dev": "2.1.0-3ubuntu0.11+esm2",
            "libgd-dev": "2.1.0-3ubuntu0.11+esm2",
            "libgd-tools": "2.1.0-3ubuntu0.11+esm2",
            "libgd3": "2.1.0-3ubuntu0.11+esm2",
            "libgd2-noxpm-dev": "2.1.0-3ubuntu0.11+esm2"
        }
    ]
}

Ubuntu:18.04:LTS / libgd2

Package

Name
libgd2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.5-4ubuntu0.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgd-dev": "2.2.5-4ubuntu0.5",
            "libgd-tools": "2.2.5-4ubuntu0.5",
            "libgd3": "2.2.5-4ubuntu0.5"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / libgd2

Package

Name
libgd2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.1-4ubuntu0.16.04.12+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libgd-dev": "2.1.1-4ubuntu0.16.04.12+esm1",
            "libgd-tools": "2.1.1-4ubuntu0.16.04.12+esm1",
            "libgd3": "2.1.1-4ubuntu0.16.04.12+esm1"
        }
    ]
}