USN-5135-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5135-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5135-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5135-1
Related
  • CVE-2021-3759
Published
2021-11-09T02:06:55Z
Modified
2021-11-09T02:06:55Z
Summary
linux, linux-aws, linux-aws-5.11, linux-azure, linux-azure-5.11, linux-gcp, linux-gcp-5.11, linux-hwe-5.11, linux-kvm, linux-oem-5.13, linux-oracle, linux-oracle-5.11, linux-raspi vulnerability
Details

It was discovered that the Linux kernel did not properly account for the memory usage of certain IPC objects. A local attacker could use this to cause a denial of service (memory exhaustion).

References

Affected packages

Ubuntu:20.04:LTS / linux-oracle-5.11

Package

Name
linux-oracle-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1021.22~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-oracle-5.11-tools-5.11.0-1021": "5.11.0-1021.22~20.04.1",
            "linux-oracle-5.11-headers-5.11.0-1021": "5.11.0-1021.22~20.04.1",
            "linux-tools-5.11.0-1021-oracle": "5.11.0-1021.22~20.04.1",
            "linux-tools-oracle-edge": "5.11.0.1021.22~20.04.14",
            "linux-oracle": "5.11.0.1021.22~20.04.14",
            "linux-modules-5.11.0-1021-oracle": "5.11.0-1021.22~20.04.1",
            "linux-image-5.11.0-1021-oracle": "5.11.0-1021.22~20.04.1",
            "linux-modules-extra-5.11.0-1021-oracle": "5.11.0-1021.22~20.04.1",
            "linux-headers-oracle": "5.11.0.1021.22~20.04.14",
            "linux-image-unsigned-5.11.0-1021-oracle": "5.11.0-1021.22~20.04.1",
            "linux-oracle-edge": "5.11.0.1021.22~20.04.14",
            "linux-image-oracle-edge": "5.11.0.1021.22~20.04.14",
            "linux-headers-oracle-edge": "5.11.0.1021.22~20.04.14",
            "linux-buildinfo-5.11.0-1021-oracle": "5.11.0-1021.22~20.04.1",
            "linux-tools-oracle": "5.11.0.1021.22~20.04.14",
            "linux-image-oracle": "5.11.0.1021.22~20.04.14",
            "linux-headers-5.11.0-1021-oracle": "5.11.0-1021.22~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oem-5.13

Package

Name
linux-oem-5.13

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.13.0-1019.23

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-oem-20.04c": "5.13.0.1019.23",
            "linux-oem-20.04c": "5.13.0.1019.23",
            "linux-tools-oem-20.04c": "5.13.0.1019.23",
            "linux-image-5.13.0-1019-oem": "5.13.0-1019.23",
            "linux-tools-5.13.0-1019-oem": "5.13.0-1019.23",
            "linux-modules-5.13.0-1019-oem": "5.13.0-1019.23",
            "linux-oem-5.13-headers-5.13.0-1019": "5.13.0-1019.23",
            "linux-headers-5.13.0-1019-oem": "5.13.0-1019.23",
            "linux-image-unsigned-5.13.0-1019-oem": "5.13.0-1019.23",
            "linux-oem-5.13-tools-host": "5.13.0-1019.23",
            "linux-buildinfo-5.13.0-1019-oem": "5.13.0-1019.23",
            "linux-headers-oem-20.04c": "5.13.0.1019.23",
            "linux-oem-5.13-tools-5.13.0-1019": "5.13.0-1019.23"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure-5.11

Package

Name
linux-azure-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1021.22~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-cloud-tools-5.11.0-1021-azure": "5.11.0-1021.22~20.04.1",
            "linux-modules-extra-azure": "5.11.0.1021.22~20.04.21",
            "linux-azure-5.11-cloud-tools-5.11.0-1021": "5.11.0-1021.22~20.04.1",
            "linux-azure": "5.11.0.1021.22~20.04.21",
            "linux-image-unsigned-5.11.0-1021-azure": "5.11.0-1021.22~20.04.1",
            "linux-headers-5.11.0-1021-azure": "5.11.0-1021.22~20.04.1",
            "linux-image-5.11.0-1021-azure": "5.11.0-1021.22~20.04.1",
            "linux-buildinfo-5.11.0-1021-azure": "5.11.0-1021.22~20.04.1",
            "linux-modules-extra-5.11.0-1021-azure": "5.11.0-1021.22~20.04.1",
            "linux-azure-edge": "5.11.0.1021.22~20.04.21",
            "linux-headers-azure-edge": "5.11.0.1021.22~20.04.21",
            "linux-headers-azure": "5.11.0.1021.22~20.04.21",
            "linux-tools-azure-edge": "5.11.0.1021.22~20.04.21",
            "linux-cloud-tools-azure": "5.11.0.1021.22~20.04.21",
            "linux-tools-azure": "5.11.0.1021.22~20.04.21",
            "linux-modules-5.11.0-1021-azure": "5.11.0-1021.22~20.04.1",
            "linux-azure-5.11-headers-5.11.0-1021": "5.11.0-1021.22~20.04.1",
            "linux-cloud-tools-azure-edge": "5.11.0.1021.22~20.04.21",
            "linux-image-azure": "5.11.0.1021.22~20.04.21",
            "linux-image-azure-edge": "5.11.0.1021.22~20.04.21",
            "linux-tools-5.11.0-1021-azure": "5.11.0-1021.22~20.04.1",
            "linux-azure-5.11-tools-5.11.0-1021": "5.11.0-1021.22~20.04.1",
            "linux-modules-extra-azure-edge": "5.11.0.1021.22~20.04.21"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws-5.11

Package

Name
linux-aws-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1021.22~20.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-5.11.0-1021-aws": "5.11.0-1021.22~20.04.2",
            "linux-image-aws-edge": "5.11.0.1021.22~20.04.20",
            "linux-aws-5.11-cloud-tools-5.11.0-1021": "5.11.0-1021.22~20.04.2",
            "linux-cloud-tools-5.11.0-1021-aws": "5.11.0-1021.22~20.04.2",
            "linux-headers-aws": "5.11.0.1021.22~20.04.20",
            "linux-image-5.11.0-1021-aws": "5.11.0-1021.22~20.04.2",
            "linux-image-aws": "5.11.0.1021.22~20.04.20",
            "linux-aws": "5.11.0.1021.22~20.04.20",
            "linux-aws-5.11-tools-5.11.0-1021": "5.11.0-1021.22~20.04.2",
            "linux-buildinfo-5.11.0-1021-aws": "5.11.0-1021.22~20.04.2",
            "linux-modules-extra-aws": "5.11.0.1021.22~20.04.20",
            "linux-modules-extra-aws-edge": "5.11.0.1021.22~20.04.20",
            "linux-headers-5.11.0-1021-aws": "5.11.0-1021.22~20.04.2",
            "linux-modules-extra-5.11.0-1021-aws": "5.11.0-1021.22~20.04.2",
            "linux-aws-5.11-headers-5.11.0-1021": "5.11.0-1021.22~20.04.2",
            "linux-tools-aws-edge": "5.11.0.1021.22~20.04.20",
            "linux-modules-5.11.0-1021-aws": "5.11.0-1021.22~20.04.2",
            "linux-headers-aws-edge": "5.11.0.1021.22~20.04.20",
            "linux-aws-edge": "5.11.0.1021.22~20.04.20",
            "linux-tools-aws": "5.11.0.1021.22~20.04.20"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp-5.11

Package

Name
linux-gcp-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1022.24~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gcp": "5.11.0.1022.24~20.04.21",
            "linux-buildinfo-5.11.0-1022-gcp": "5.11.0-1022.24~20.04.1",
            "linux-tools-5.11.0-1022-gcp": "5.11.0-1022.24~20.04.1",
            "linux-gcp-5.11-headers-5.11.0-1022": "5.11.0-1022.24~20.04.1",
            "linux-image-5.11.0-1022-gcp": "5.11.0-1022.24~20.04.1",
            "linux-tools-gcp-edge": "5.11.0.1022.24~20.04.21",
            "linux-gcp": "5.11.0.1022.24~20.04.21",
            "linux-headers-gcp-edge": "5.11.0.1022.24~20.04.21",
            "linux-image-gcp-edge": "5.11.0.1022.24~20.04.21",
            "linux-modules-extra-5.11.0-1022-gcp": "5.11.0-1022.24~20.04.1",
            "linux-gcp-5.11-tools-5.11.0-1022": "5.11.0-1022.24~20.04.1",
            "linux-image-gcp": "5.11.0.1022.24~20.04.21",
            "linux-modules-5.11.0-1022-gcp": "5.11.0-1022.24~20.04.1",
            "linux-modules-extra-gcp-edge": "5.11.0.1022.24~20.04.21",
            "linux-gcp-edge": "5.11.0.1022.24~20.04.21",
            "linux-modules-extra-gcp": "5.11.0.1022.24~20.04.21",
            "linux-headers-gcp": "5.11.0.1022.24~20.04.21",
            "linux-image-unsigned-5.11.0-1022-gcp": "5.11.0-1022.24~20.04.1",
            "linux-headers-5.11.0-1022-gcp": "5.11.0-1022.24~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-hwe-5.11

Package

Name
linux-hwe-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-40.44~20.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-buildinfo-5.11.0-40-generic": "5.11.0-40.44~20.04.2",
            "linux-buildinfo-5.11.0-40-generic-lpae": "5.11.0-40.44~20.04.2",
            "linux-hwe-5.11-tools-host": "5.11.0-40.44~20.04.2",
            "linux-hwe-5.11-cloud-tools-5.11.0-40": "5.11.0-40.44~20.04.2",
            "linux-tools-generic-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-image-generic-lpae-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-headers-generic-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-hwe-5.11-source-5.11.0": "5.11.0-40.44~20.04.2",
            "linux-image-generic-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-image-generic-64k-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-headers-generic-lpae-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-modules-5.11.0-40-generic-64k": "5.11.0-40.44~20.04.2",
            "linux-modules-extra-5.11.0-40-generic": "5.11.0-40.44~20.04.2",
            "linux-headers-5.11.0-40-generic-64k": "5.11.0-40.44~20.04.2",
            "linux-tools-5.11.0-40-lowlatency": "5.11.0-40.44~20.04.2",
            "linux-image-unsigned-5.11.0-40-lowlatency": "5.11.0-40.44~20.04.2",
            "linux-headers-5.11.0-40-lowlatency": "5.11.0-40.44~20.04.2",
            "linux-tools-5.11.0-40-generic-64k": "5.11.0-40.44~20.04.2",
            "linux-generic-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-lowlatency-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-image-5.11.0-40-generic-lpae": "5.11.0-40.44~20.04.2",
            "linux-generic-64k-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-image-extra-virtual-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-tools-virtual-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-tools-generic-lpae-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-cloud-tools-5.11.0-40-generic": "5.11.0-40.44~20.04.2",
            "linux-headers-lowlatency-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-tools-5.11.0-40-generic": "5.11.0-40.44~20.04.2",
            "linux-image-unsigned-5.11.0-40-generic": "5.11.0-40.44~20.04.2",
            "linux-buildinfo-5.11.0-40-lowlatency": "5.11.0-40.44~20.04.2",
            "linux-generic-lpae-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-cloud-tools-generic-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-virtual-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-image-5.11.0-40-lowlatency": "5.11.0-40.44~20.04.2",
            "linux-modules-5.11.0-40-generic": "5.11.0-40.44~20.04.2",
            "linux-hwe-5.11-cloud-tools-common": "5.11.0-40.44~20.04.2",
            "linux-modules-5.11.0-40-generic-lpae": "5.11.0-40.44~20.04.2",
            "linux-image-lowlatency-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-hwe-5.11-headers-5.11.0-40": "5.11.0-40.44~20.04.2",
            "linux-image-unsigned-5.11.0-40-generic-64k": "5.11.0-40.44~20.04.2",
            "linux-tools-5.11.0-40-generic-lpae": "5.11.0-40.44~20.04.2",
            "linux-headers-5.11.0-40-generic-lpae": "5.11.0-40.44~20.04.2",
            "linux-modules-5.11.0-40-lowlatency": "5.11.0-40.44~20.04.2",
            "linux-hwe-5.11-tools-5.11.0-40": "5.11.0-40.44~20.04.2",
            "linux-cloud-tools-virtual-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-headers-generic-64k-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-tools-lowlatency-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-image-virtual-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-headers-virtual-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-image-5.11.0-40-generic-64k": "5.11.0-40.44~20.04.2",
            "linux-image-5.11.0-40-generic": "5.11.0-40.44~20.04.2",
            "linux-cloud-tools-lowlatency-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-tools-generic-64k-hwe-20.04": "5.11.0.40.44~20.04.18",
            "linux-buildinfo-5.11.0-40-generic-64k": "5.11.0-40.44~20.04.2",
            "linux-headers-5.11.0-40-generic": "5.11.0-40.44~20.04.2",
            "linux-cloud-tools-5.11.0-40-lowlatency": "5.11.0-40.44~20.04.2",
            "linux-hwe-5.11-tools-common": "5.11.0-40.44~20.04.2"
        }
    ]
}