USN-5172-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5172-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5172-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5172-1
Related
Published
2021-12-06T12:53:01.218019Z
Modified
2021-12-06T12:53:01.218019Z
Summary
uriparser vulnerabilities
Details

It was discovered that uriparser mishandled certain input. An attacker could use this vulnerability to cause uriparser to crash or possibly execute arbitrary code. (CVE-2018-19198, CVE-2018-19199, CVE-2018-19200)

It was discovered that uriparser incorrectly handled certain URIs. An attacker could use this vulnerability to cause a crash or possibly leak sensitive information. (CVE-2018-20721)

References

Affected packages

Ubuntu:18.04:LTS / uriparser

Package

Name
uriparser

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.8.4-1+deb9u2build0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "liburiparser1": "0.8.4-1+deb9u2build0.18.04.1",
            "liburiparser-dev": "0.8.4-1+deb9u2build0.18.04.1",
            "liburiparser-doc": "0.8.4-1+deb9u2build0.18.04.1"
        }
    ]
}