USN-5237-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5237-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5237-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5237-1
Related
Published
2022-08-01T05:54:27.047272Z
Modified
2022-08-01T05:54:27.047272Z
Summary
libmediainfo vulnerabilities
Details

It was discovered that MediaInfoLib incorrectly handled certain specially crafted files. An attacker could possibly use this issue to cause a denial of service. (CVE-2020-26797)

It was discovered that MediaInfoLib incorrectly handled certain specially crafted MpegPs files. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2020-15395)

References

Affected packages

Ubuntu:Pro:20.04:LTS / libmediainfo

Package

Name
libmediainfo

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
19.09+dfsg-2ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libmediainfo0v5": "19.09+dfsg-2ubuntu0.1~esm1",
            "libmediainfo-dev": "19.09+dfsg-2ubuntu0.1~esm1",
            "python3-mediainfodll": "19.09+dfsg-2ubuntu0.1~esm1",
            "libmediainfo-doc": "19.09+dfsg-2ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / libmediainfo

Package

Name
libmediainfo

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.67-2ubuntu1+esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libmediainfo0": "0.7.67-2ubuntu1+esm2",
            "python-mediainfodll": "0.7.67-2ubuntu1+esm2",
            "libmediainfo-dev": "0.7.67-2ubuntu1+esm2",
            "python3-mediainfodll": "0.7.67-2ubuntu1+esm2",
            "libmediainfo-doc": "0.7.67-2ubuntu1+esm2"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / libmediainfo

Package

Name
libmediainfo

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
17.12-1ubuntu0.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libmediainfo0v5": "17.12-1ubuntu0.1+esm1",
            "python-mediainfodll": "17.12-1ubuntu0.1+esm1",
            "libmediainfo-dev": "17.12-1ubuntu0.1+esm1",
            "python3-mediainfodll": "17.12-1ubuntu0.1+esm1",
            "libmediainfo-doc": "17.12-1ubuntu0.1+esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / libmediainfo

Package

Name
libmediainfo

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.82-1ubuntu0.1~esm2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libmediainfo0v5": "0.7.82-1ubuntu0.1~esm2",
            "python-mediainfodll": "0.7.82-1ubuntu0.1~esm2",
            "libmediainfo-dev": "0.7.82-1ubuntu0.1~esm2",
            "python3-mediainfodll": "0.7.82-1ubuntu0.1~esm2",
            "libmediainfo-doc": "0.7.82-1ubuntu0.1~esm2"
        }
    ]
}