USN-5240-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5240-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5240-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5240-1
Related
  • CVE-2022-0185
Published
2022-01-19T17:37:58.423583Z
Modified
2022-01-19T17:37:58.423583Z
Summary
linux, linux-aws, linux-aws-5.11, linux-aws-5.4, linux-azure, linux-azure-5.11, linux-azure-5.4, linux-bluefield, linux-gcp, linux-gcp-5.11, linux-gcp-5.4, linux-gke, linux-gke-5.4, linux-gkeop, linux-gkeop-5.4, linux-hwe-5.4, linux-ibm, linux-kvm, linux-oem-5.10, linux-oem-5.13, linux-oem-5.14, linux-oracle, linux-oracle-5.11, linux-oracle-5.4, linux-raspi, linux-raspi-5.4 vulnerability
Details

William Liu and Jamie Hill-Daniel discovered that the file system context functionality in the Linux kernel contained an integer underflow vulnerability, leading to an out-of-bounds write. A local attacker could use this to cause a denial of service (system crash) or execute arbitrary code.

References

Affected packages

Ubuntu:18.04:LTS / linux-gke-5.4

Package

Name
linux-gke-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1059.62~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-5.4.0-1059-gke": "5.4.0-1059.62~18.04.1",
            "linux-tools-5.4.0-1059-gke": "5.4.0-1059.62~18.04.1",
            "linux-gke-5.4": "5.4.0.1059.62~18.04.23",
            "linux-tools-gke-5.4": "5.4.0.1059.62~18.04.23",
            "linux-modules-5.4.0-1059-gke": "5.4.0-1059.62~18.04.1",
            "linux-buildinfo-5.4.0-1059-gke": "5.4.0-1059.62~18.04.1",
            "linux-image-5.4.0-1059-gke": "5.4.0-1059.62~18.04.1",
            "linux-gke-5.4-tools-5.4.0-1059": "5.4.0-1059.62~18.04.1",
            "linux-headers-gke-5.4": "5.4.0.1059.62~18.04.23",
            "linux-gke-5.4-headers-5.4.0-1059": "5.4.0-1059.62~18.04.1",
            "linux-modules-extra-gke-5.4": "5.4.0.1059.62~18.04.23",
            "linux-image-unsigned-5.4.0-1059-gke": "5.4.0-1059.62~18.04.1",
            "linux-modules-extra-5.4.0-1059-gke": "5.4.0-1059.62~18.04.1",
            "linux-image-gke-5.4": "5.4.0.1059.62~18.04.23"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gcp-5.4

Package

Name
linux-gcp-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1062.66~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gcp": "5.4.0.1062.47",
            "linux-modules-5.4.0-1062-gcp": "5.4.0-1062.66~18.04.1",
            "linux-tools-gcp-edge": "5.4.0.1062.47",
            "linux-gcp": "5.4.0.1062.47",
            "linux-headers-gcp-edge": "5.4.0.1062.47",
            "linux-image-gcp-edge": "5.4.0.1062.47",
            "linux-gcp-5.4-headers-5.4.0-1062": "5.4.0-1062.66~18.04.1",
            "linux-image-5.4.0-1062-gcp": "5.4.0-1062.66~18.04.1",
            "linux-headers-gcp": "5.4.0.1062.47",
            "linux-modules-extra-gcp": "5.4.0.1062.47",
            "linux-headers-5.4.0-1062-gcp": "5.4.0-1062.66~18.04.1",
            "linux-gcp-edge": "5.4.0.1062.47",
            "linux-modules-extra-gcp-edge": "5.4.0.1062.47",
            "linux-gcp-5.4-tools-5.4.0-1062": "5.4.0-1062.66~18.04.1",
            "linux-modules-extra-5.4.0-1062-gcp": "5.4.0-1062.66~18.04.1",
            "linux-image-unsigned-5.4.0-1062-gcp": "5.4.0-1062.66~18.04.1",
            "linux-tools-5.4.0-1062-gcp": "5.4.0-1062.66~18.04.1",
            "linux-image-gcp": "5.4.0.1062.47",
            "linux-buildinfo-5.4.0-1062-gcp": "5.4.0-1062.66~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-azure-5.4

Package

Name
linux-azure-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1067.70~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-5.4.0-1067-azure": "5.4.0-1067.70~18.04.1",
            "linux-modules-5.4.0-1067-azure": "5.4.0-1067.70~18.04.1",
            "linux-modules-extra-azure": "5.4.0.1067.46",
            "linux-signed-image-azure": "5.4.0.1067.46",
            "linux-azure-5.4-headers-5.4.0-1067": "5.4.0-1067.70~18.04.1",
            "linux-azure": "5.4.0.1067.46",
            "linux-buildinfo-5.4.0-1067-azure": "5.4.0-1067.70~18.04.1",
            "linux-image-5.4.0-1067-azure": "5.4.0-1067.70~18.04.1",
            "linux-azure-5.4-tools-5.4.0-1067": "5.4.0-1067.70~18.04.1",
            "linux-signed-azure": "5.4.0.1067.46",
            "linux-azure-edge": "5.4.0.1067.46",
            "linux-headers-azure-edge": "5.4.0.1067.46",
            "linux-image-unsigned-5.4.0-1067-azure": "5.4.0-1067.70~18.04.1",
            "linux-azure-5.4-cloud-tools-5.4.0-1067": "5.4.0-1067.70~18.04.1",
            "linux-tools-azure-edge": "5.4.0.1067.46",
            "linux-cloud-tools-azure": "5.4.0.1067.46",
            "linux-tools-azure": "5.4.0.1067.46",
            "linux-modules-extra-5.4.0-1067-azure": "5.4.0-1067.70~18.04.1",
            "linux-cloud-tools-azure-edge": "5.4.0.1067.46",
            "linux-headers-5.4.0-1067-azure": "5.4.0-1067.70~18.04.1",
            "linux-image-azure": "5.4.0.1067.46",
            "linux-headers-azure": "5.4.0.1067.46",
            "linux-image-azure-edge": "5.4.0.1067.46",
            "linux-signed-azure-edge": "5.4.0.1067.46",
            "linux-signed-image-azure-edge": "5.4.0.1067.46",
            "linux-cloud-tools-5.4.0-1067-azure": "5.4.0-1067.70~18.04.1",
            "linux-modules-extra-azure-edge": "5.4.0.1067.46"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gkeop-5.4

Package

Name
linux-gkeop-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1031.32~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-gkeop-5.4": "5.4.0.1031.32~18.04.31",
            "linux-headers-gkeop-5.4": "5.4.0.1031.32~18.04.31",
            "linux-gkeop-5.4": "5.4.0.1031.32~18.04.31",
            "linux-modules-extra-5.4.0-1031-gkeop": "5.4.0-1031.32~18.04.1",
            "linux-buildinfo-5.4.0-1031-gkeop": "5.4.0-1031.32~18.04.1",
            "linux-headers-5.4.0-1031-gkeop": "5.4.0-1031.32~18.04.1",
            "linux-gkeop-5.4-headers-5.4.0-1031": "5.4.0-1031.32~18.04.1",
            "linux-image-5.4.0-1031-gkeop": "5.4.0-1031.32~18.04.1",
            "linux-cloud-tools-5.4.0-1031-gkeop": "5.4.0-1031.32~18.04.1",
            "linux-cloud-tools-gkeop-5.4": "5.4.0.1031.32~18.04.31",
            "linux-tools-5.4.0-1031-gkeop": "5.4.0-1031.32~18.04.1",
            "linux-gkeop-5.4-tools-5.4.0-1031": "5.4.0-1031.32~18.04.1",
            "linux-gkeop-5.4-cloud-tools-5.4.0-1031": "5.4.0-1031.32~18.04.1",
            "linux-modules-extra-gkeop-5.4": "5.4.0.1031.32~18.04.31",
            "linux-gkeop-5.4-source-5.4.0": "5.4.0-1031.32~18.04.1",
            "linux-modules-5.4.0-1031-gkeop": "5.4.0-1031.32~18.04.1",
            "linux-image-unsigned-5.4.0-1031-gkeop": "5.4.0-1031.32~18.04.1",
            "linux-tools-gkeop-5.4": "5.4.0.1031.32~18.04.31"
        }
    ]
}

Ubuntu:18.04:LTS / linux-hwe-5.4

Package

Name
linux-hwe-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-96.109~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-snapdragon-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-headers-oem": "5.4.0.96.109~18.04.84",
            "linux-image-snapdragon-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-image-unsigned-5.4.0-96-generic": "5.4.0-96.109~18.04.1",
            "linux-lowlatency-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-generic-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-modules-5.4.0-96-lowlatency": "5.4.0-96.109~18.04.1",
            "linux-snapdragon-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-image-unsigned-5.4.0-96-lowlatency": "5.4.0-96.109~18.04.1",
            "linux-tools-snapdragon-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-headers-generic-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-generic-lpae-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-generic-lpae-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-tools-generic-lpae-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-cloud-tools-5.4.0-96-generic": "5.4.0-96.109~18.04.1",
            "linux-snapdragon-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-oem": "5.4.0.96.109~18.04.84",
            "linux-cloud-tools-5.4.0-96-lowlatency": "5.4.0-96.109~18.04.1",
            "linux-headers-5.4.0-96-generic-lpae": "5.4.0-96.109~18.04.1",
            "linux-image-5.4.0-96-generic-lpae": "5.4.0-96.109~18.04.1",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-hwe-5.4-cloud-tools-common": "5.4.0-96.109~18.04.1",
            "linux-hwe-5.4-tools-5.4.0-96": "5.4.0-96.109~18.04.1",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-image-5.4.0-96-lowlatency": "5.4.0-96.109~18.04.1",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-modules-5.4.0-96-generic-lpae": "5.4.0-96.109~18.04.1",
            "linux-modules-extra-virtual-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-generic-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-hwe-5.4-headers-5.4.0-96": "5.4.0-96.109~18.04.1",
            "linux-headers-snapdragon-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-headers-oem-osp1": "5.4.0.96.109~18.04.84",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-buildinfo-5.4.0-96-lowlatency": "5.4.0-96.109~18.04.1",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-hwe-5.4-source-5.4.0": "5.4.0-96.109~18.04.1",
            "linux-tools-5.4.0-96-generic": "5.4.0-96.109~18.04.1",
            "linux-hwe-5.4-cloud-tools-5.4.0-96": "5.4.0-96.109~18.04.1",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-headers-generic-lpae-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-headers-virtual-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-tools-oem-osp1": "5.4.0.96.109~18.04.84",
            "linux-modules-extra-virtual-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-oem-osp1": "5.4.0.96.109~18.04.84",
            "linux-headers-5.4.0-96-lowlatency": "5.4.0-96.109~18.04.1",
            "linux-tools-oem": "5.4.0.96.109~18.04.84",
            "linux-tools-generic-lpae-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-hwe-5.4-tools-common": "5.4.0-96.109~18.04.1",
            "linux-tools-5.4.0-96-generic-lpae": "5.4.0-96.109~18.04.1",
            "linux-image-oem": "5.4.0.96.109~18.04.84",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-image-5.4.0-96-generic": "5.4.0-96.109~18.04.1",
            "linux-headers-5.4.0-96-generic": "5.4.0-96.109~18.04.1",
            "linux-virtual-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-buildinfo-5.4.0-96-generic-lpae": "5.4.0-96.109~18.04.1",
            "linux-virtual-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-image-generic-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-tools-5.4.0-96-lowlatency": "5.4.0-96.109~18.04.1",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-modules-5.4.0-96-generic": "5.4.0-96.109~18.04.1",
            "linux-image-virtual-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-headers-generic-lpae-hwe-18.04-edge": "5.4.0.96.109~18.04.84",
            "linux-image-oem-osp1": "5.4.0.96.109~18.04.84",
            "linux-tools-virtual-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-image-snapdragon-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-modules-extra-5.4.0-96-generic": "5.4.0-96.109~18.04.1",
            "linux-tools-snapdragon-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-tools-generic-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-buildinfo-5.4.0-96-generic": "5.4.0-96.109~18.04.1",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.96.109~18.04.84",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.96.109~18.04.84"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oracle-5.4

Package

Name
linux-oracle-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1061.65~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-extra-oracle-edge": "5.4.0.1061.65~18.04.40",
            "linux-headers-5.4.0-1061-oracle": "5.4.0-1061.65~18.04.1",
            "linux-image-unsigned-5.4.0-1061-oracle": "5.4.0-1061.65~18.04.1",
            "linux-oracle-5.4-tools-5.4.0-1061": "5.4.0-1061.65~18.04.1",
            "linux-oracle-5.4-headers-5.4.0-1061": "5.4.0-1061.65~18.04.1",
            "linux-tools-5.4.0-1061-oracle": "5.4.0-1061.65~18.04.1",
            "linux-modules-5.4.0-1061-oracle": "5.4.0-1061.65~18.04.1",
            "linux-signed-oracle-edge": "5.4.0.1061.65~18.04.40",
            "linux-oracle-edge": "5.4.0.1061.65~18.04.40",
            "linux-buildinfo-5.4.0-1061-oracle": "5.4.0-1061.65~18.04.1",
            "linux-tools-oracle-edge": "5.4.0.1061.65~18.04.40",
            "linux-signed-image-oracle": "5.4.0.1061.65~18.04.40",
            "linux-signed-oracle": "5.4.0.1061.65~18.04.40",
            "linux-modules-extra-5.4.0-1061-oracle": "5.4.0-1061.65~18.04.1",
            "linux-oracle": "5.4.0.1061.65~18.04.40",
            "linux-headers-oracle": "5.4.0.1061.65~18.04.40",
            "linux-modules-extra-oracle": "5.4.0.1061.65~18.04.40",
            "linux-headers-oracle-edge": "5.4.0.1061.65~18.04.40",
            "linux-signed-image-oracle-edge": "5.4.0.1061.65~18.04.40",
            "linux-image-5.4.0-1061-oracle": "5.4.0-1061.65~18.04.1",
            "linux-tools-oracle": "5.4.0.1061.65~18.04.40",
            "linux-image-oracle": "5.4.0.1061.65~18.04.40",
            "linux-image-oracle-edge": "5.4.0.1061.65~18.04.40"
        }
    ]
}

Ubuntu:18.04:LTS / linux-aws-5.4

Package

Name
linux-aws-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1063.66~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-5.4.0-1063-aws": "5.4.0-1063.66~18.04.1",
            "linux-modules-5.4.0-1063-aws": "5.4.0-1063.66~18.04.1",
            "linux-image-aws-edge": "5.4.0.1063.45",
            "linux-headers-aws": "5.4.0.1063.45",
            "linux-image-unsigned-5.4.0-1063-aws": "5.4.0-1063.66~18.04.1",
            "linux-image-aws": "5.4.0.1063.45",
            "linux-cloud-tools-5.4.0-1063-aws": "5.4.0-1063.66~18.04.1",
            "linux-aws-5.4-headers-5.4.0-1063": "5.4.0-1063.66~18.04.1",
            "linux-aws": "5.4.0.1063.45",
            "linux-headers-aws-edge": "5.4.0.1063.45",
            "linux-modules-extra-aws": "5.4.0.1063.45",
            "linux-modules-extra-aws-edge": "5.4.0.1063.45",
            "linux-aws-5.4-cloud-tools-5.4.0-1063": "5.4.0-1063.66~18.04.1",
            "linux-aws-5.4-tools-5.4.0-1063": "5.4.0-1063.66~18.04.1",
            "linux-tools-aws-edge": "5.4.0.1063.45",
            "linux-modules-extra-5.4.0-1063-aws": "5.4.0-1063.66~18.04.1",
            "linux-buildinfo-5.4.0-1063-aws": "5.4.0-1063.66~18.04.1",
            "linux-aws-edge": "5.4.0.1063.45",
            "linux-tools-5.4.0-1063-aws": "5.4.0-1063.66~18.04.1",
            "linux-tools-aws": "5.4.0.1063.45"
        }
    ]
}

Ubuntu:18.04:LTS / linux-raspi-5.4

Package

Name
linux-raspi-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1050.56~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-raspi-hwe-18.04-edge": "5.4.0.1050.52",
            "linux-buildinfo-5.4.0-1050-raspi": "5.4.0-1050.56~18.04.1",
            "linux-raspi-5.4-headers-5.4.0-1050": "5.4.0-1050.56~18.04.1",
            "linux-modules-5.4.0-1050-raspi": "5.4.0-1050.56~18.04.1",
            "linux-tools-raspi-hwe-18.04-edge": "5.4.0.1050.52",
            "linux-raspi-hwe-18.04-edge": "5.4.0.1050.52",
            "linux-headers-5.4.0-1050-raspi": "5.4.0-1050.56~18.04.1",
            "linux-image-raspi-hwe-18.04": "5.4.0.1050.52",
            "linux-raspi-hwe-18.04": "5.4.0.1050.52",
            "linux-image-5.4.0-1050-raspi": "5.4.0-1050.56~18.04.1",
            "linux-headers-raspi-hwe-18.04-edge": "5.4.0.1050.52",
            "linux-headers-raspi-hwe-18.04": "5.4.0.1050.52",
            "linux-tools-5.4.0-1050-raspi": "5.4.0-1050.56~18.04.1",
            "linux-tools-raspi-hwe-18.04": "5.4.0.1050.52",
            "linux-raspi-5.4-tools-5.4.0-1050": "5.4.0-1050.56~18.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oracle-5.11

Package

Name
linux-oracle-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1027.30~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-buildinfo-5.11.0-1027-oracle": "5.11.0-1027.30~20.04.1",
            "linux-image-oracle": "5.11.0.1027.30~20.04.19",
            "linux-image-5.11.0-1027-oracle": "5.11.0-1027.30~20.04.1",
            "linux-oracle-5.11-headers-5.11.0-1027": "5.11.0-1027.30~20.04.1",
            "linux-headers-5.11.0-1027-oracle": "5.11.0-1027.30~20.04.1",
            "linux-modules-5.11.0-1027-oracle": "5.11.0-1027.30~20.04.1",
            "linux-modules-extra-5.11.0-1027-oracle": "5.11.0-1027.30~20.04.1",
            "linux-headers-oracle": "5.11.0.1027.30~20.04.19",
            "linux-oracle": "5.11.0.1027.30~20.04.19",
            "linux-image-unsigned-5.11.0-1027-oracle": "5.11.0-1027.30~20.04.1",
            "linux-tools-oracle": "5.11.0.1027.30~20.04.19",
            "linux-oracle-5.11-tools-5.11.0-1027": "5.11.0-1027.30~20.04.1",
            "linux-tools-5.11.0-1027-oracle": "5.11.0-1027.30~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oem-5.14

Package

Name
linux-oem-5.14

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.14.0-1020.22

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-oem-5.14-tools-host": "5.14.0-1020.22",
            "linux-headers-5.14.0-1020-oem": "5.14.0-1020.22",
            "linux-buildinfo-5.14.0-1020-oem": "5.14.0-1020.22",
            "linux-tools-5.14.0-1020-oem": "5.14.0-1020.22",
            "linux-tools-oem-20.04d": "5.14.0.1020.17",
            "linux-image-oem-20.04d": "5.14.0.1020.17",
            "linux-oem-5.14-headers-5.14.0-1020": "5.14.0-1020.22",
            "linux-modules-5.14.0-1020-oem": "5.14.0-1020.22",
            "linux-image-5.14.0-1020-oem": "5.14.0-1020.22",
            "linux-oem-20.04d": "5.14.0.1020.17",
            "linux-headers-oem-20.04d": "5.14.0.1020.17",
            "linux-image-unsigned-5.14.0-1020-oem": "5.14.0-1020.22",
            "linux-oem-5.14-tools-5.14.0-1020": "5.14.0-1020.22"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oem-5.13

Package

Name
linux-oem-5.13

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.13.0-1028.35

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-oem-20.04c": "5.13.0.1028.30",
            "linux-image-unsigned-5.13.0-1028-oem": "5.13.0-1028.35",
            "linux-tools-oem-20.04c": "5.13.0.1028.30",
            "linux-buildinfo-5.13.0-1028-oem": "5.13.0-1028.35",
            "linux-oem-20.04c": "5.13.0.1028.30",
            "linux-modules-5.13.0-1028-oem": "5.13.0-1028.35",
            "linux-tools-5.13.0-1028-oem": "5.13.0-1028.35",
            "linux-oem-5.13-headers-5.13.0-1028": "5.13.0-1028.35",
            "linux-oem-5.13-tools-5.13.0-1028": "5.13.0-1028.35",
            "linux-image-5.13.0-1028-oem": "5.13.0-1028.35",
            "linux-oem-5.13-tools-host": "5.13.0-1028.35",
            "linux-headers-oem-20.04c": "5.13.0.1028.30",
            "linux-headers-5.13.0-1028-oem": "5.13.0-1028.35"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gkeop

Package

Name
linux-gkeop

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1031.32

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-gkeop-5.4": "5.4.0.1031.34",
            "linux-image-gkeop-5.4": "5.4.0.1031.34",
            "linux-gkeop-5.4": "5.4.0.1031.34",
            "linux-modules-extra-5.4.0-1031-gkeop": "5.4.0-1031.32",
            "linux-tools-gkeop": "5.4.0.1031.34",
            "linux-cloud-tools-gkeop": "5.4.0.1031.34",
            "linux-gkeop": "5.4.0.1031.34",
            "linux-buildinfo-5.4.0-1031-gkeop": "5.4.0-1031.32",
            "linux-modules-extra-gkeop": "5.4.0.1031.34",
            "linux-headers-5.4.0-1031-gkeop": "5.4.0-1031.32",
            "linux-image-gkeop": "5.4.0.1031.34",
            "linux-image-5.4.0-1031-gkeop": "5.4.0-1031.32",
            "linux-cloud-tools-5.4.0-1031-gkeop": "5.4.0-1031.32",
            "linux-cloud-tools-gkeop-5.4": "5.4.0.1031.34",
            "linux-tools-5.4.0-1031-gkeop": "5.4.0-1031.32",
            "linux-gkeop-source-5.4.0": "5.4.0-1031.32",
            "linux-modules-extra-gkeop-5.4": "5.4.0.1031.34",
            "linux-modules-5.4.0-1031-gkeop": "5.4.0-1031.32",
            "linux-image-unsigned-5.4.0-1031-gkeop": "5.4.0-1031.32",
            "linux-tools-gkeop-5.4": "5.4.0.1031.34",
            "linux-gkeop-cloud-tools-5.4.0-1031": "5.4.0-1031.32",
            "linux-gkeop-tools-5.4.0-1031": "5.4.0-1031.32",
            "linux-gkeop-headers-5.4.0-1031": "5.4.0-1031.32",
            "linux-headers-gkeop": "5.4.0.1031.34"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws-5.11

Package

Name
linux-aws-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1027.30~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-aws": "5.11.0.1027.30~20.04.25",
            "linux-modules-5.11.0-1027-aws": "5.11.0-1027.30~20.04.1",
            "linux-aws-5.11-cloud-tools-5.11.0-1027": "5.11.0-1027.30~20.04.1",
            "linux-headers-5.11.0-1027-aws": "5.11.0-1027.30~20.04.1",
            "linux-image-aws": "5.11.0.1027.30~20.04.25",
            "linux-aws": "5.11.0.1027.30~20.04.25",
            "linux-modules-extra-5.11.0-1027-aws": "5.11.0-1027.30~20.04.1",
            "linux-buildinfo-5.11.0-1027-aws": "5.11.0-1027.30~20.04.1",
            "linux-modules-extra-aws": "5.11.0.1027.30~20.04.25",
            "linux-cloud-tools-5.11.0-1027-aws": "5.11.0-1027.30~20.04.1",
            "linux-tools-5.11.0-1027-aws": "5.11.0-1027.30~20.04.1",
            "linux-aws-5.11-headers-5.11.0-1027": "5.11.0-1027.30~20.04.1",
            "linux-aws-5.11-tools-5.11.0-1027": "5.11.0-1027.30~20.04.1",
            "linux-image-5.11.0-1027-aws": "5.11.0-1027.30~20.04.1",
            "linux-tools-aws": "5.11.0.1027.30~20.04.25"
        }
    ]
}

Ubuntu:20.04:LTS / linux-bluefield

Package

Name
linux-bluefield

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1025.28

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-bluefield": "5.4.0.1025.26",
            "linux-image-unsigned-5.4.0-1025-bluefield": "5.4.0-1025.28",
            "linux-tools-5.4.0-1025-bluefield": "5.4.0-1025.28",
            "linux-image-bluefield": "5.4.0.1025.26",
            "linux-headers-bluefield": "5.4.0.1025.26",
            "linux-bluefield-headers-5.4.0-1025": "5.4.0-1025.28",
            "linux-buildinfo-5.4.0-1025-bluefield": "5.4.0-1025.28",
            "linux-headers-5.4.0-1025-bluefield": "5.4.0-1025.28",
            "linux-modules-5.4.0-1025-bluefield": "5.4.0-1025.28",
            "linux-tools-bluefield": "5.4.0.1025.26",
            "linux-image-5.4.0-1025-bluefield": "5.4.0-1025.28",
            "linux-bluefield-tools-5.4.0-1025": "5.4.0-1025.28"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1067.70

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-5.4.0-1067-azure": "5.4.0-1067.70",
            "linux-tools-5.4.0-1067-azure": "5.4.0-1067.70",
            "linux-tools-azure-lts-20.04": "5.4.0.1067.65",
            "linux-buildinfo-5.4.0-1067-azure": "5.4.0-1067.70",
            "linux-azure-tools-5.4.0-1067": "5.4.0-1067.70",
            "linux-image-5.4.0-1067-azure": "5.4.0-1067.70",
            "linux-modules-extra-azure-lts-20.04": "5.4.0.1067.65",
            "linux-image-unsigned-5.4.0-1067-azure": "5.4.0-1067.70",
            "linux-cloud-tools-azure-lts-20.04": "5.4.0.1067.65",
            "linux-image-azure-lts-20.04": "5.4.0.1067.65",
            "linux-headers-azure-lts-20.04": "5.4.0.1067.65",
            "linux-modules-extra-5.4.0-1067-azure": "5.4.0-1067.70",
            "linux-headers-5.4.0-1067-azure": "5.4.0-1067.70",
            "linux-azure-lts-20.04": "5.4.0.1067.65",
            "linux-azure-cloud-tools-5.4.0-1067": "5.4.0-1067.70",
            "linux-azure-headers-5.4.0-1067": "5.4.0-1067.70",
            "linux-cloud-tools-5.4.0-1067-azure": "5.4.0-1067.70"
        }
    ]
}

Ubuntu:20.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-96.109

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-generic-hwe-18.04": "5.4.0.96.100",
            "linux-headers-oem": "5.4.0.96.100",
            "linux-tools-virtual-hwe-18.04-edge": "5.4.0.96.100",
            "linux-image-unsigned-5.4.0-96-generic": "5.4.0-96.109",
            "linux-lowlatency-hwe-18.04": "5.4.0.96.100",
            "linux-lowlatency-hwe-18.04-edge": "5.4.0.96.100",
            "linux-modules-5.4.0-96-lowlatency": "5.4.0-96.109",
            "linux-cloud-tools-virtual": "5.4.0.96.100",
            "linux-image-unsigned-5.4.0-96-lowlatency": "5.4.0-96.109",
            "linux-headers-lowlatency-hwe-18.04-edge": "5.4.0.96.100",
            "linux-generic-lpae-hwe-18.04": "5.4.0.96.100",
            "linux-headers-generic-hwe-18.04": "5.4.0.96.100",
            "linux-generic-lpae-hwe-18.04-edge": "5.4.0.96.100",
            "linux-tools-virtual": "5.4.0.96.100",
            "linux-oem-osp1-tools-host": "5.4.0.96.100",
            "linux-cloud-tools-generic-hwe-18.04": "5.4.0.96.100",
            "linux-cloud-tools-5.4.0-96-generic": "5.4.0-96.109",
            "linux-tools-generic-lpae-hwe-18.04": "5.4.0.96.100",
            "linux-source": "5.4.0.96.100",
            "linux-image-extra-virtual": "5.4.0.96.100",
            "linux-oem": "5.4.0.96.100",
            "linux-cloud-tools-5.4.0-96-lowlatency": "5.4.0-96.109",
            "linux-cloud-tools-generic": "5.4.0.96.100",
            "linux-image-virtual": "5.4.0.96.100",
            "linux-image-5.4.0-96-generic-lpae": "5.4.0-96.109",
            "linux-tools-generic": "5.4.0.96.100",
            "linux-headers-5.4.0-96-generic-lpae": "5.4.0-96.109",
            "linux-cloud-tools-lowlatency": "5.4.0.96.100",
            "linux-generic-lpae": "5.4.0.96.100",
            "linux-virtual": "5.4.0.96.100",
            "linux-cloud-tools-lowlatency-hwe-18.04-edge": "5.4.0.96.100",
            "linux-tools-5.4.0-96": "5.4.0-96.109",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.96.100",
            "linux-image-5.4.0-96-lowlatency": "5.4.0-96.109",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.96.100",
            "linux-cloud-tools-lowlatency-hwe-18.04": "5.4.0.96.100",
            "linux-crashdump": "5.4.0.96.100",
            "linux-generic": "5.4.0.96.100",
            "linux-headers-lowlatency-hwe-18.04": "5.4.0.96.100",
            "linux-headers-virtual-hwe-18.04-edge": "5.4.0.96.100",
            "linux-tools-generic-hwe-18.04-edge": "5.4.0.96.100",
            "linux-modules-5.4.0-96-generic-lpae": "5.4.0-96.109",
            "linux-generic-hwe-18.04-edge": "5.4.0.96.100",
            "linux-cloud-tools-5.4.0-96": "5.4.0-96.109",
            "linux-headers-generic-lpae": "5.4.0.96.100",
            "linux-tools-lowlatency-hwe-18.04-edge": "5.4.0.96.100",
            "linux-image-generic-lpae": "5.4.0.96.100",
            "linux-tools-lowlatency": "5.4.0.96.100",
            "linux-headers-generic-hwe-18.04-edge": "5.4.0.96.100",
            "linux-cloud-tools-common": "5.4.0-96.109",
            "linux-buildinfo-5.4.0-96-lowlatency": "5.4.0-96.109",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.96.100",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.96.100",
            "linux-libc-dev": "5.4.0-96.109",
            "linux-source-5.4.0": "5.4.0-96.109",
            "linux-cloud-tools-generic-hwe-18.04-edge": "5.4.0.96.100",
            "linux-tools-5.4.0-96-generic": "5.4.0-96.109",
            "linux-doc": "5.4.0-96.109",
            "linux-headers-virtual-hwe-18.04": "5.4.0.96.100",
            "linux-headers-generic-lpae-hwe-18.04": "5.4.0.96.100",
            "linux-tools-oem-osp1": "5.4.0.96.100",
            "linux-oem-osp1": "5.4.0.96.100",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.96.100",
            "linux-headers-5.4.0-96-lowlatency": "5.4.0-96.109",
            "linux-headers-oem-osp1": "5.4.0.96.100",
            "linux-headers-5.4.0-96": "5.4.0-96.109",
            "linux-headers-generic": "5.4.0.96.100",
            "linux-tools-oem": "5.4.0.96.100",
            "linux-image-lowlatency": "5.4.0.96.100",
            "linux-oem-tools-host": "5.4.0.96.100",
            "linux-tools-generic-lpae-hwe-18.04-edge": "5.4.0.96.100",
            "linux-headers-virtual": "5.4.0.96.100",
            "linux-headers-lowlatency": "5.4.0.96.100",
            "linux-tools-5.4.0-96-generic-lpae": "5.4.0-96.109",
            "linux-image-oem": "5.4.0.96.100",
            "linux-cloud-tools-virtual-hwe-18.04-edge": "5.4.0.96.100",
            "linux-headers-5.4.0-96-generic": "5.4.0-96.109",
            "linux-image-5.4.0-96-generic": "5.4.0-96.109",
            "linux-tools-host": "5.4.0-96.109",
            "linux-virtual-hwe-18.04": "5.4.0.96.100",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.96.100",
            "linux-virtual-hwe-18.04-edge": "5.4.0.96.100",
            "linux-buildinfo-5.4.0-96-generic-lpae": "5.4.0-96.109",
            "linux-image-generic-hwe-18.04": "5.4.0.96.100",
            "linux-tools-5.4.0-96-lowlatency": "5.4.0-96.109",
            "linux-cloud-tools-virtual-hwe-18.04": "5.4.0.96.100",
            "linux-modules-5.4.0-96-generic": "5.4.0-96.109",
            "linux-tools-generic-lpae": "5.4.0.96.100",
            "linux-tools-virtual-hwe-18.04": "5.4.0.96.100",
            "linux-image-oem-osp1": "5.4.0.96.100",
            "linux-image-extra-virtual-hwe-18.04-edge": "5.4.0.96.100",
            "linux-headers-generic-lpae-hwe-18.04-edge": "5.4.0.96.100",
            "linux-image-virtual-hwe-18.04": "5.4.0.96.100",
            "linux-modules-extra-5.4.0-96-generic": "5.4.0-96.109",
            "linux-tools-generic-hwe-18.04": "5.4.0.96.100",
            "linux-lowlatency": "5.4.0.96.100",
            "linux-buildinfo-5.4.0-96-generic": "5.4.0-96.109",
            "linux-image-generic": "5.4.0.96.100",
            "linux-tools-common": "5.4.0-96.109",
            "linux-tools-lowlatency-hwe-18.04": "5.4.0.96.100",
            "linux-image-extra-virtual-hwe-18.04": "5.4.0.96.100"
        }
    ]
}

Ubuntu:20.04:LTS / linux-kvm

Package

Name
linux-kvm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1053.55

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.4.0-1053-kvm": "5.4.0-1053.55",
            "linux-headers-kvm": "5.4.0.1053.52",
            "linux-kvm": "5.4.0.1053.52",
            "linux-image-unsigned-5.4.0-1053-kvm": "5.4.0-1053.55",
            "linux-modules-5.4.0-1053-kvm": "5.4.0-1053.55",
            "linux-buildinfo-5.4.0-1053-kvm": "5.4.0-1053.55",
            "linux-tools-kvm": "5.4.0.1053.52",
            "linux-kvm-tools-5.4.0-1053": "5.4.0-1053.55",
            "linux-headers-5.4.0-1053-kvm": "5.4.0-1053.55",
            "linux-kvm-headers-5.4.0-1053": "5.4.0-1053.55",
            "linux-tools-5.4.0-1053-kvm": "5.4.0-1053.55",
            "linux-image-kvm": "5.4.0.1053.52"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oem-5.10

Package

Name
linux-oem-5.10

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.10.0-1057.61

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-oem-5.10-tools-5.10.0-1057": "5.10.0-1057.61",
            "linux-oem-20.04-edge": "5.10.0.1057.57",
            "linux-oem-5.10-tools-host": "5.10.0-1057.61",
            "linux-headers-oem-20.04b": "5.10.0.1057.57",
            "linux-oem-20.04b": "5.10.0.1057.57",
            "linux-tools-5.10.0-1057-oem": "5.10.0-1057.61",
            "linux-image-oem-20.04": "5.10.0.1057.57",
            "linux-image-oem-20.04-edge": "5.10.0.1057.57",
            "linux-headers-5.10.0-1057-oem": "5.10.0-1057.61",
            "linux-tools-oem-20.04-edge": "5.10.0.1057.57",
            "linux-oem-20.04": "5.10.0.1057.57",
            "linux-headers-oem-20.04-edge": "5.10.0.1057.57",
            "linux-headers-oem-20.04": "5.10.0.1057.57",
            "linux-oem-5.10-headers-5.10.0-1057": "5.10.0-1057.61",
            "linux-tools-oem-20.04": "5.10.0.1057.57",
            "linux-tools-oem-20.04b": "5.10.0.1057.57",
            "linux-image-oem-20.04b": "5.10.0.1057.57",
            "linux-modules-5.10.0-1057-oem": "5.10.0-1057.61",
            "linux-image-unsigned-5.10.0-1057-oem": "5.10.0-1057.61",
            "linux-buildinfo-5.10.0-1057-oem": "5.10.0-1057.61",
            "linux-image-5.10.0-1057-oem": "5.10.0-1057.61"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1063.66

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-5.4.0-1063-aws": "5.4.0-1063.66",
            "linux-modules-5.4.0-1063-aws": "5.4.0-1063.66",
            "linux-modules-extra-aws-lts-20.04": "5.4.0.1063.65",
            "linux-aws-lts-20.04": "5.4.0.1063.65",
            "linux-aws-tools-5.4.0-1063": "5.4.0-1063.66",
            "linux-image-unsigned-5.4.0-1063-aws": "5.4.0-1063.66",
            "linux-tools-aws-lts-20.04": "5.4.0.1063.65",
            "linux-cloud-tools-5.4.0-1063-aws": "5.4.0-1063.66",
            "linux-aws-cloud-tools-5.4.0-1063": "5.4.0-1063.66",
            "linux-headers-aws-lts-20.04": "5.4.0.1063.65",
            "linux-aws-headers-5.4.0-1063": "5.4.0-1063.66",
            "linux-modules-extra-5.4.0-1063-aws": "5.4.0-1063.66",
            "linux-buildinfo-5.4.0-1063-aws": "5.4.0-1063.66",
            "linux-tools-5.4.0-1063-aws": "5.4.0-1063.66",
            "linux-image-aws-lts-20.04": "5.4.0.1063.65"
        }
    ]
}

Ubuntu:20.04:LTS / linux-raspi

Package

Name
linux-raspi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1050.56

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-raspi2-hwe-18.04-edge": "5.4.0.1050.84",
            "linux-buildinfo-5.4.0-1050-raspi": "5.4.0-1050.56",
            "linux-raspi-tools-5.4.0-1050": "5.4.0-1050.56",
            "linux-headers-raspi": "5.4.0.1050.84",
            "linux-tools-raspi-hwe-18.04-edge": "5.4.0.1050.84",
            "linux-image-raspi2": "5.4.0.1050.84",
            "linux-raspi-hwe-18.04-edge": "5.4.0.1050.84",
            "linux-image-5.4.0-1050-raspi": "5.4.0-1050.56",
            "linux-headers-raspi-hwe-18.04-edge": "5.4.0.1050.84",
            "linux-raspi2-hwe-18.04-edge": "5.4.0.1050.84",
            "linux-tools-5.4.0-1050-raspi": "5.4.0-1050.56",
            "linux-headers-raspi-hwe-18.04": "5.4.0.1050.84",
            "linux-headers-raspi2-hwe-18.04": "5.4.0.1050.84",
            "linux-image-raspi": "5.4.0.1050.84",
            "linux-image-raspi2-hwe-18.04": "5.4.0.1050.84",
            "linux-image-raspi-hwe-18.04-edge": "5.4.0.1050.84",
            "linux-tools-raspi2-hwe-18.04-edge": "5.4.0.1050.84",
            "linux-headers-raspi2-hwe-18.04-edge": "5.4.0.1050.84",
            "linux-tools-raspi": "5.4.0.1050.84",
            "linux-modules-5.4.0-1050-raspi": "5.4.0-1050.56",
            "linux-raspi-headers-5.4.0-1050": "5.4.0-1050.56",
            "linux-headers-5.4.0-1050-raspi": "5.4.0-1050.56",
            "linux-image-raspi-hwe-18.04": "5.4.0.1050.84",
            "linux-raspi2-hwe-18.04": "5.4.0.1050.84",
            "linux-raspi": "5.4.0.1050.84",
            "linux-tools-raspi2-hwe-18.04": "5.4.0.1050.84",
            "linux-headers-raspi2": "5.4.0.1050.84",
            "linux-tools-raspi2": "5.4.0.1050.84",
            "linux-raspi-hwe-18.04": "5.4.0.1050.84",
            "linux-raspi2": "5.4.0.1050.84",
            "linux-tools-raspi-hwe-18.04": "5.4.0.1050.84"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure-5.11

Package

Name
linux-azure-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1027.30~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.11.0-1027-azure": "5.11.0-1027.30~20.04.1",
            "linux-azure-5.11-headers-5.11.0-1027": "5.11.0-1027.30~20.04.1",
            "linux-modules-extra-azure": "5.11.0.1027.30~20.04.25",
            "linux-headers-5.11.0-1027-azure": "5.11.0-1027.30~20.04.1",
            "linux-azure": "5.11.0.1027.30~20.04.25",
            "linux-azure-5.11-tools-5.11.0-1027": "5.11.0-1027.30~20.04.1",
            "linux-cloud-tools-5.11.0-1027-azure": "5.11.0-1027.30~20.04.1",
            "linux-tools-5.11.0-1027-azure": "5.11.0-1027.30~20.04.1",
            "linux-azure-5.11-cloud-tools-5.11.0-1027": "5.11.0-1027.30~20.04.1",
            "linux-headers-azure": "5.11.0.1027.30~20.04.25",
            "linux-tools-azure": "5.11.0.1027.30~20.04.25",
            "linux-cloud-tools-azure": "5.11.0.1027.30~20.04.25",
            "linux-image-azure": "5.11.0.1027.30~20.04.25",
            "linux-modules-5.11.0-1027-azure": "5.11.0-1027.30~20.04.1",
            "linux-buildinfo-5.11.0-1027-azure": "5.11.0-1027.30~20.04.1",
            "linux-modules-extra-5.11.0-1027-azure": "5.11.0-1027.30~20.04.1",
            "linux-image-unsigned-5.11.0-1027-azure": "5.11.0-1027.30~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp-5.11

Package

Name
linux-gcp-5.11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.11.0-1028.32~20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gcp": "5.11.0.1028.32~20.04.26",
            "linux-gcp": "5.11.0.1028.32~20.04.26",
            "linux-tools-5.11.0-1028-gcp": "5.11.0-1028.32~20.04.1",
            "linux-image-5.11.0-1028-gcp": "5.11.0-1028.32~20.04.1",
            "linux-image-gcp": "5.11.0.1028.32~20.04.26",
            "linux-headers-gcp": "5.11.0.1028.32~20.04.26",
            "linux-modules-extra-gcp": "5.11.0.1028.32~20.04.26",
            "linux-headers-5.11.0-1028-gcp": "5.11.0-1028.32~20.04.1",
            "linux-buildinfo-5.11.0-1028-gcp": "5.11.0-1028.32~20.04.1",
            "linux-image-unsigned-5.11.0-1028-gcp": "5.11.0-1028.32~20.04.1",
            "linux-modules-5.11.0-1028-gcp": "5.11.0-1028.32~20.04.1",
            "linux-gcp-5.11-tools-5.11.0-1028": "5.11.0-1028.32~20.04.1",
            "linux-modules-extra-5.11.0-1028-gcp": "5.11.0-1028.32~20.04.1",
            "linux-gcp-5.11-headers-5.11.0-1028": "5.11.0-1028.32~20.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gke

Package

Name
linux-gke

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1059.62

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-gke": "5.4.0.1059.69",
            "linux-headers-5.4.0-1059-gke": "5.4.0-1059.62",
            "linux-gke-tools-5.4.0-1059": "5.4.0-1059.62",
            "linux-tools-5.4.0-1059-gke": "5.4.0-1059.62",
            "linux-headers-gke": "5.4.0.1059.69",
            "linux-gke-5.4": "5.4.0.1059.69",
            "linux-tools-gke-5.4": "5.4.0.1059.69",
            "linux-modules-5.4.0-1059-gke": "5.4.0-1059.62",
            "linux-buildinfo-5.4.0-1059-gke": "5.4.0-1059.62",
            "linux-gke": "5.4.0.1059.69",
            "linux-gke-headers-5.4.0-1059": "5.4.0-1059.62",
            "linux-image-5.4.0-1059-gke": "5.4.0-1059.62",
            "linux-headers-gke-5.4": "5.4.0.1059.69",
            "linux-modules-extra-gke-5.4": "5.4.0.1059.69",
            "linux-image-unsigned-5.4.0-1059-gke": "5.4.0-1059.62",
            "linux-modules-extra-5.4.0-1059-gke": "5.4.0-1059.62",
            "linux-image-gke": "5.4.0.1059.69",
            "linux-image-gke-5.4": "5.4.0.1059.69",
            "linux-modules-extra-gke": "5.4.0.1059.69"
        }
    ]
}

Ubuntu:20.04:LTS / linux-ibm

Package

Name
linux-ibm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1012.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-ibm-lts-20.04": "5.4.0.1012.13",
            "linux-tools-ibm-lts-20.04": "5.4.0.1012.13",
            "linux-ibm-headers-5.4.0-1012": "5.4.0-1012.13",
            "linux-modules-extra-ibm": "5.4.0.1012.13",
            "linux-image-5.4.0-1012-ibm": "5.4.0-1012.13",
            "linux-headers-5.4.0-1012-ibm": "5.4.0-1012.13",
            "linux-buildinfo-5.4.0-1012-ibm": "5.4.0-1012.13",
            "linux-ibm-tools-5.4.0-1012": "5.4.0-1012.13",
            "linux-tools-ibm": "5.4.0.1012.13",
            "linux-ibm-tools-common": "5.4.0-1012.13",
            "linux-ibm-lts-20.04": "5.4.0.1012.13",
            "linux-headers-ibm": "5.4.0.1012.13",
            "linux-ibm": "5.4.0.1012.13",
            "linux-modules-extra-ibm-lts-20.04": "5.4.0.1012.13",
            "linux-tools-5.4.0-1012-ibm": "5.4.0-1012.13",
            "linux-image-ibm-lts-20.04": "5.4.0.1012.13",
            "linux-modules-5.4.0-1012-ibm": "5.4.0-1012.13",
            "linux-ibm-source-5.4.0": "5.4.0-1012.13",
            "linux-modules-extra-5.4.0-1012-ibm": "5.4.0-1012.13",
            "linux-ibm-cloud-tools-common": "5.4.0-1012.13",
            "linux-image-ibm": "5.4.0.1012.13",
            "linux-image-unsigned-5.4.0-1012-ibm": "5.4.0-1012.13"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1062.66

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-gcp-headers-5.4.0-1062": "5.4.0-1062.66",
            "linux-modules-extra-gcp-lts-20.04": "5.4.0.1062.72",
            "linux-modules-5.4.0-1062-gcp": "5.4.0-1062.66",
            "linux-image-gcp-lts-20.04": "5.4.0.1062.72",
            "linux-tools-gcp-lts-20.04": "5.4.0.1062.72",
            "linux-image-5.4.0-1062-gcp": "5.4.0-1062.66",
            "linux-gcp-tools-5.4.0-1062": "5.4.0-1062.66",
            "linux-headers-5.4.0-1062-gcp": "5.4.0-1062.66",
            "linux-tools-5.4.0-1062-gcp": "5.4.0-1062.66",
            "linux-modules-extra-5.4.0-1062-gcp": "5.4.0-1062.66",
            "linux-image-unsigned-5.4.0-1062-gcp": "5.4.0-1062.66",
            "linux-headers-gcp-lts-20.04": "5.4.0.1062.72",
            "linux-gcp-lts-20.04": "5.4.0.1062.72",
            "linux-buildinfo-5.4.0-1062-gcp": "5.4.0-1062.66"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1061.65

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-oracle-lts-20.04": "5.4.0.1061.61",
            "linux-image-unsigned-5.4.0-1061-oracle": "5.4.0-1061.65",
            "linux-oracle-lts-20.04": "5.4.0.1061.61",
            "linux-oracle-headers-5.4.0-1061": "5.4.0-1061.65",
            "linux-headers-oracle-lts-20.04": "5.4.0.1061.61",
            "linux-modules-5.4.0-1061-oracle": "5.4.0-1061.65",
            "linux-headers-5.4.0-1061-oracle": "5.4.0-1061.65",
            "linux-oracle-tools-5.4.0-1061": "5.4.0-1061.65",
            "linux-modules-extra-5.4.0-1061-oracle": "5.4.0-1061.65",
            "linux-buildinfo-5.4.0-1061-oracle": "5.4.0-1061.65",
            "linux-image-5.4.0-1061-oracle": "5.4.0-1061.65",
            "linux-tools-5.4.0-1061-oracle": "5.4.0-1061.65",
            "linux-tools-oracle-lts-20.04": "5.4.0.1061.61"
        }
    ]
}