USN-5399-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5399-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5399-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5399-1
Related
Published
2022-05-02T17:01:25.873658Z
Modified
2022-05-02T17:01:25.873658Z
Summary
libvirt vulnerabilities
Details

It was discovered that libvirt incorrectly handled certain locking operations. A local attacker could possibly use this issue to cause libvirt to stop accepting connections, resulting in a denial of service. This issue only affected Ubuntu 20.04 LTS. (CVE-2021-3667)

It was discovered that libvirt incorrectly handled threads during shutdown. A local attacker could possibly use this issue to cause libvirt to crash, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2021-3975)

It was discovered that libvirt incorrectly handled the libxl driver. An attacker inside a guest could possibly use this issue to cause libvirtd to crash or stop responding, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 21.10. (CVE-2021-4147)

It was discovered that libvirt incorrectly handled the nwfilter driver. A local attacker could possibly use this issue to cause libvirt to crash, resulting in a denial of service. (CVE-2022-0897)

It was discovered that libvirt incorrectly handled the polkit access control driver. A local attacker could possibly use this issue to cause libvirt to crash, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-25637)

It was discovered that libvirt incorrectly generated SELinux labels. In environments using SELinux, this issue could allow the sVirt confinement to be bypassed. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2021-3631)

References

Affected packages

Ubuntu:18.04:LTS / libvirt

Package

Name
libvirt

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.0.0-1ubuntu8.21

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libvirt-daemon-driver-storage-rbd": "4.0.0-1ubuntu8.21",
            "libvirt-doc": "4.0.0-1ubuntu8.21",
            "libvirt-sanlock": "4.0.0-1ubuntu8.21",
            "libvirt-daemon-driver-storage-sheepdog": "4.0.0-1ubuntu8.21",
            "libvirt-dev": "4.0.0-1ubuntu8.21",
            "libvirt-clients": "4.0.0-1ubuntu8.21",
            "libvirt0": "4.0.0-1ubuntu8.21",
            "libvirt-daemon-driver-storage-zfs": "4.0.0-1ubuntu8.21",
            "libvirt-wireshark": "4.0.0-1ubuntu8.21",
            "libvirt-daemon-system": "4.0.0-1ubuntu8.21",
            "libnss-libvirt": "4.0.0-1ubuntu8.21",
            "libvirt-daemon-driver-storage-gluster": "4.0.0-1ubuntu8.21",
            "libvirt-daemon": "4.0.0-1ubuntu8.21",
            "libvirt-bin": "4.0.0-1ubuntu8.21"
        }
    ]
}

Ubuntu:20.04:LTS / libvirt

Package

Name
libvirt

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.0.0-0ubuntu8.16

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libvirt-doc": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-driver-storage-rbd": "6.0.0-0ubuntu8.16",
            "libvirt-sanlock": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-system-systemd": "6.0.0-0ubuntu8.16",
            "libvirt-dev": "6.0.0-0ubuntu8.16",
            "libvirt-clients": "6.0.0-0ubuntu8.16",
            "libvirt0": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-driver-storage-zfs": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-driver-vbox": "6.0.0-0ubuntu8.16",
            "libvirt-wireshark": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-system-sysv": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-driver-xen": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-driver-qemu": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-system": "6.0.0-0ubuntu8.16",
            "libnss-libvirt": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-driver-lxc": "6.0.0-0ubuntu8.16",
            "libvirt-daemon-driver-storage-gluster": "6.0.0-0ubuntu8.16",
            "libvirt-daemon": "6.0.0-0ubuntu8.16"
        }
    ]
}