USN-5402-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5402-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5402-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5402-1
Related
Published
2022-05-04T13:21:13.465238Z
Modified
2022-05-04T13:21:13.465238Z
Summary
openssl, openssl1.0 vulnerabilities
Details

Elison Niven discovered that OpenSSL incorrectly handled the crehash script. A local attacker could possibly use this issue to execute arbitrary commands when crehash is run. (CVE-2022-1292)

Raul Metsma discovered that OpenSSL incorrectly verified certain response signing certificates. A remote attacker could possibly use this issue to spoof certain response signing certificates. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-1343)

Tom Colley discovered that OpenSSL used the incorrect MAC key in the RC4-MD5 ciphersuite. In non-default configurations were RC4-MD5 is enabled, a remote attacker could possibly use this issue to modify encrypted communications. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-1434)

Aliaksei Levin discovered that OpenSSL incorrectly handled resources when decoding certificates and keys. A remote attacker could possibly use this issue to cause OpenSSL to consume resources, leading to a denial of service. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-1473)

References

Affected packages

Ubuntu:22.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.2-0ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl3": "3.0.2-0ubuntu1.1",
            "libssl-dev": "3.0.2-0ubuntu1.1",
            "openssl": "3.0.2-0ubuntu1.1",
            "libssl-doc": "3.0.2-0ubuntu1.1"
        }
    ]
}

Ubuntu:20.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.1f-1ubuntu2.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl1.1": "1.1.1f-1ubuntu2.13",
            "libssl-dev": "1.1.1f-1ubuntu2.13",
            "openssl": "1.1.1f-1ubuntu2.13",
            "libssl-doc": "1.1.1f-1ubuntu2.13"
        }
    ]
}

Ubuntu:18.04:LTS / openssl1.0

Package

Name
openssl1.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.2n-1ubuntu5.9

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl1.0-dev": "1.0.2n-1ubuntu5.9",
            "openssl1.0": "1.0.2n-1ubuntu5.9",
            "libssl1.0.0": "1.0.2n-1ubuntu5.9"
        }
    ]
}

Ubuntu:18.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.1-1ubuntu2.1~18.04.17

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl-dev": "1.1.1-1ubuntu2.1~18.04.17",
            "openssl": "1.1.1-1ubuntu2.1~18.04.17",
            "libssl-doc": "1.1.1-1ubuntu2.1~18.04.17",
            "libssl1.1": "1.1.1-1ubuntu2.1~18.04.17"
        }
    ]
}