USN-5446-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5446-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5446-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5446-1
Related
Published
2022-05-26T11:16:17.956226Z
Modified
2022-05-26T11:16:17.956226Z
Summary
dpkg vulnerability
Details

Max Justicz discovered that dpkg incorrectly handled unpacking certain source packages. If a user or an automated system were tricked into unpacking a specially crafted source package, a remote attacker could modify files outside the target unpack directory, leading to a denial of service or potentially gaining access to the system.

References

Affected packages

Ubuntu:22.04:LTS / dpkg

Package

Name
dpkg

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.21.1ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libdpkg-dev": "1.21.1ubuntu2.1",
            "libdpkg-perl": "1.21.1ubuntu2.1",
            "dpkg-dev": "1.21.1ubuntu2.1",
            "dselect": "1.21.1ubuntu2.1",
            "dpkg": "1.21.1ubuntu2.1"
        }
    ]
}

Ubuntu:18.04:LTS / dpkg

Package

Name
dpkg

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.19.0.5ubuntu2.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libdpkg-dev": "1.19.0.5ubuntu2.4",
            "libdpkg-perl": "1.19.0.5ubuntu2.4",
            "dpkg-dev": "1.19.0.5ubuntu2.4",
            "dselect": "1.19.0.5ubuntu2.4",
            "dpkg": "1.19.0.5ubuntu2.4"
        }
    ]
}

Ubuntu:20.04:LTS / dpkg

Package

Name
dpkg

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.19.7ubuntu3.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libdpkg-dev": "1.19.7ubuntu3.2",
            "libdpkg-perl": "1.19.7ubuntu3.2",
            "dpkg-dev": "1.19.7ubuntu3.2",
            "dselect": "1.19.7ubuntu3.2",
            "dpkg": "1.19.7ubuntu3.2"
        }
    ]
}