USN-5760-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-5760-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5760-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5760-2
Related
Published
2022-12-05T13:34:52.442209Z
Modified
2022-12-05T13:34:52.442209Z
Summary
libxml2 vulnerabilities
Details

USN-5760-1 fixed vulnerabilities in libxml2. This update provides the corresponding updates for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.

Original advisory details:

It was discovered that libxml2 incorrectly handled certain XML files. An attacker could possibly use this issue to expose sensitive information or cause a crash. (CVE-2022-40303)

It was discovered that libxml2 incorrectly handled certain XML files. An attacker could possibly use this issue to execute arbitrary code. (CVE-2022-40304)

References

Affected packages

Ubuntu:Pro:14.04:LTS / libxml2

Package

Name
libxml2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.1+dfsg1-3ubuntu4.13+esm4

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libxml2": "2.9.1+dfsg1-3ubuntu4.13+esm4",
            "libxml2-doc": "2.9.1+dfsg1-3ubuntu4.13+esm4",
            "libxml2-dev": "2.9.1+dfsg1-3ubuntu4.13+esm4",
            "libxml2-utils": "2.9.1+dfsg1-3ubuntu4.13+esm4",
            "python-libxml2": "2.9.1+dfsg1-3ubuntu4.13+esm4"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / libxml2

Package

Name
libxml2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.3+dfsg1-1ubuntu0.7+esm4

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libxml2": "2.9.3+dfsg1-1ubuntu0.7+esm4",
            "libxml2-doc": "2.9.3+dfsg1-1ubuntu0.7+esm4",
            "libxml2-dev": "2.9.3+dfsg1-1ubuntu0.7+esm4",
            "libxml2-utils": "2.9.3+dfsg1-1ubuntu0.7+esm4",
            "python-libxml2": "2.9.3+dfsg1-1ubuntu0.7+esm4"
        }
    ]
}