USN-5894-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5894-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5894-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5894-1
Related
Published
2023-02-27T14:10:27.200105Z
Modified
2023-02-27T14:10:27.200105Z
Summary
curl vulnerabilities
Details

Harry Sintonen and Tomas Hoger discovered that curl incorrectly handled TELNET connections when the -t option was used on the command line. Uninitialized data possibly containing sensitive information could be sent to the remote server, contrary to expectations. This issue was only fixed in Ubuntu 14.04 ESM. (CVE-2021-22898, CVE-2021-22925)

It was discovered that curl incorrectly handled denials when using HTTP proxies. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2022-43552)

References

Affected packages

Ubuntu:Pro:14.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.35.0-1ubuntu2.20+esm14

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "curl": "7.35.0-1ubuntu2.20+esm14",
            "libcurl3": "7.35.0-1ubuntu2.20+esm14",
            "libcurl4-gnutls-dev": "7.35.0-1ubuntu2.20+esm14",
            "libcurl3-gnutls": "7.35.0-1ubuntu2.20+esm14",
            "libcurl4-doc": "7.35.0-1ubuntu2.20+esm14",
            "libcurl3-nss": "7.35.0-1ubuntu2.20+esm14",
            "libcurl4-nss-dev": "7.35.0-1ubuntu2.20+esm14",
            "libcurl4-openssl-dev": "7.35.0-1ubuntu2.20+esm14"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.47.0-1ubuntu2.19+esm7

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "curl": "7.47.0-1ubuntu2.19+esm7",
            "libcurl3": "7.47.0-1ubuntu2.19+esm7",
            "libcurl4-gnutls-dev": "7.47.0-1ubuntu2.19+esm7",
            "libcurl3-gnutls": "7.47.0-1ubuntu2.19+esm7",
            "libcurl4-doc": "7.47.0-1ubuntu2.19+esm7",
            "libcurl3-nss": "7.47.0-1ubuntu2.19+esm7",
            "libcurl4-nss-dev": "7.47.0-1ubuntu2.19+esm7",
            "libcurl4-openssl-dev": "7.47.0-1ubuntu2.19+esm7"
        }
    ]
}