USN-5906-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-5906-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-5906-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-5906-1
Related
Published
2023-03-02T12:38:26.881948Z
Modified
2023-03-02T12:38:26.881948Z
Summary
postgresql-12, postgresql-14 vulnerability
Details

Jacob Champion discovered that the PostgreSQL client incorrectly handled Kerberos authentication. If a user or automated system were tricked into connecting to a malicious server, a remote attacker could possibly use this issue to obtain sensitive information.

References

Affected packages

Ubuntu:22.04:LTS / postgresql-14

Package

Name
postgresql-14

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
14.7-0ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "postgresql-client-14": "14.7-0ubuntu0.22.04.1",
            "libpgtypes3": "14.7-0ubuntu0.22.04.1",
            "libecpg6": "14.7-0ubuntu0.22.04.1",
            "libpq-dev": "14.7-0ubuntu0.22.04.1",
            "postgresql-doc-14": "14.7-0ubuntu0.22.04.1",
            "postgresql-server-dev-14": "14.7-0ubuntu0.22.04.1",
            "libecpg-dev": "14.7-0ubuntu0.22.04.1",
            "postgresql-pltcl-14": "14.7-0ubuntu0.22.04.1",
            "libpq5": "14.7-0ubuntu0.22.04.1",
            "postgresql-plperl-14": "14.7-0ubuntu0.22.04.1",
            "postgresql-14": "14.7-0ubuntu0.22.04.1",
            "libecpg-compat3": "14.7-0ubuntu0.22.04.1",
            "postgresql-plpython3-14": "14.7-0ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / postgresql-12

Package

Name
postgresql-12

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
12.14-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpq-dev": "12.14-0ubuntu0.20.04.1",
            "libecpg6": "12.14-0ubuntu0.20.04.1",
            "postgresql-plpython3-12": "12.14-0ubuntu0.20.04.1",
            "postgresql-doc-12": "12.14-0ubuntu0.20.04.1",
            "libpgtypes3": "12.14-0ubuntu0.20.04.1",
            "postgresql-pltcl-12": "12.14-0ubuntu0.20.04.1",
            "libecpg-dev": "12.14-0ubuntu0.20.04.1",
            "postgresql-plperl-12": "12.14-0ubuntu0.20.04.1",
            "postgresql-server-dev-12": "12.14-0ubuntu0.20.04.1",
            "postgresql-12": "12.14-0ubuntu0.20.04.1",
            "postgresql-client-12": "12.14-0ubuntu0.20.04.1",
            "libpq5": "12.14-0ubuntu0.20.04.1",
            "libecpg-compat3": "12.14-0ubuntu0.20.04.1"
        }
    ]
}