USN-6161-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6161-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6161-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6161-2
Published
2023-06-23T11:39:01.584068Z
Modified
2023-06-23T11:39:01.584068Z
Summary
dotnet6, dotnet7 regression
Details

USN-6161-1 fixed vulnerabilities in .NET. The update introduced a regression with regards to how the runtime imported X.509 certificates. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that .NET did not properly enforce certain restrictions when deserializing a DataSet or DataTable from XML. An attacker could possibly use this issue to elevate their privileges. (CVE-2023-24936)

Kevin Jones discovered that .NET did not properly handle the AIA fetching process for X.509 client certificates. An attacker could possibly use this issue to cause a denial of service. (CVE-2023-29331)

Kalle Niemitalo discovered that the .NET package manager, NuGet, was susceptible to a potential race condition. An attacker could possibly use this issue to perform remote code execution. (CVE-2023-29337)

Tom Deseyn discovered that .NET did not properly process certain arguments when extracting the contents of a tar file. An attacker could possibly use this issue to elevate their privileges. This issue only affected the dotnet7 package. (CVE-2023-32032)

It was discovered that .NET did not properly handle memory in certain circumstances. An attacker could possibly use this issue to cause a denial of service or perform remote code execution. (CVE-2023-33128)

References

Affected packages

Ubuntu:22.04:LTS / dotnet6

Package

Name
dotnet6

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.0.119-0ubuntu1~22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "dotnet-host": "6.0.119-0ubuntu1~22.04.1",
            "dotnet-templates-6.0": "6.0.119-0ubuntu1~22.04.1",
            "dotnet-hostfxr-6.0": "6.0.119-0ubuntu1~22.04.1",
            "dotnet-apphost-pack-6.0": "6.0.119-0ubuntu1~22.04.1",
            "dotnet-sdk-6.0": "6.0.119-0ubuntu1~22.04.1",
            "dotnet-sdk-6.0-source-built-artifacts": "6.0.119-0ubuntu1~22.04.1",
            "aspnetcore-runtime-6.0": "6.0.119-0ubuntu1~22.04.1",
            "netstandard-targeting-pack-2.1": "6.0.119-0ubuntu1~22.04.1",
            "dotnet6": "6.0.119-0ubuntu1~22.04.1",
            "aspnetcore-targeting-pack-6.0": "6.0.119-0ubuntu1~22.04.1",
            "dotnet-runtime-6.0": "6.0.119-0ubuntu1~22.04.1",
            "dotnet-targeting-pack-6.0": "6.0.119-0ubuntu1~22.04.1"
        }
    ]
}

Ubuntu:22.04:LTS / dotnet7

Package

Name
dotnet7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.108-0ubuntu1~22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "netstandard-targeting-pack-2.1-7.0": "7.0.108-0ubuntu1~22.04.1",
            "dotnet-sdk-7.0": "7.0.108-0ubuntu1~22.04.1",
            "aspnetcore-runtime-7.0": "7.0.108-0ubuntu1~22.04.1",
            "dotnet7": "7.0.108-0ubuntu1~22.04.1",
            "aspnetcore-targeting-pack-7.0": "7.0.108-0ubuntu1~22.04.1",
            "dotnet-apphost-pack-7.0": "7.0.108-0ubuntu1~22.04.1",
            "dotnet-runtime-7.0": "7.0.108-0ubuntu1~22.04.1",
            "dotnet-hostfxr-7.0": "7.0.108-0ubuntu1~22.04.1",
            "dotnet-host-7.0": "7.0.108-0ubuntu1~22.04.1",
            "dotnet-sdk-7.0-source-built-artifacts": "7.0.108-0ubuntu1~22.04.1",
            "dotnet-targeting-pack-7.0": "7.0.108-0ubuntu1~22.04.1",
            "dotnet-templates-7.0": "7.0.108-0ubuntu1~22.04.1"
        }
    ]
}