USN-6205-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6205-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6205-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6205-1
Related
  • CVE-2023-35788
Published
2023-07-06T18:02:53.531793Z
Modified
2023-07-06T18:02:53.531793Z
Summary
linux-gke vulnerabilities
Details

Hangyu Hua discovered that the Flower classifier implementation in the Linux kernel contained an out-of-bounds write vulnerability. An attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-35788, LP: #2023577)

It was discovered that for some Intel processors the INVLPG instruction implementation did not properly flush global TLB entries when PCIDs are enabled. An attacker could use this to expose sensitive information (kernel memory) or possibly cause undesired behaviors. (LP: #2023220)

References

Affected packages

Ubuntu:20.04:LTS / linux-gke

Package

Name
linux-gke

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1103.110

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-gke-5.4": "5.4.0.1103.108",
            "linux-gke-headers-5.4.0-1103": "5.4.0-1103.110",
            "linux-image-gke": "5.4.0.1103.108",
            "linux-modules-extra-gke-5.4": "5.4.0.1103.108",
            "linux-buildinfo-5.4.0-1103-gke": "5.4.0-1103.110",
            "linux-headers-gke": "5.4.0.1103.108",
            "linux-gke-5.4": "5.4.0.1103.108",
            "linux-tools-gke-5.4": "5.4.0.1103.108",
            "linux-gke": "5.4.0.1103.108",
            "linux-modules-extra-5.4.0-1103-gke": "5.4.0-1103.110",
            "linux-headers-gke-5.4": "5.4.0.1103.108",
            "linux-modules-5.4.0-1103-gke": "5.4.0-1103.110",
            "linux-image-unsigned-5.4.0-1103-gke": "5.4.0-1103.110",
            "linux-image-5.4.0-1103-gke": "5.4.0-1103.110",
            "linux-tools-5.4.0-1103-gke": "5.4.0-1103.110",
            "linux-modules-extra-gke": "5.4.0.1103.108",
            "linux-tools-gke": "5.4.0.1103.108",
            "linux-headers-5.4.0-1103-gke": "5.4.0-1103.110",
            "linux-gke-tools-5.4.0-1103": "5.4.0-1103.110"
        }
    ]
}