USN-6359-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6359-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6359-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6359-1
Related
Published
2023-09-12T16:23:47.314641Z
Modified
2023-09-12T16:23:47.314641Z
Summary
file vulnerability
Details

It was discovered that file incorrectly handled certain malformed files. An attacker could use this issue to cause a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:22.04:LTS / file

Package

Name
file

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:5.41-3ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "file": "1:5.41-3ubuntu0.1",
            "libmagic-dev": "1:5.41-3ubuntu0.1",
            "libmagic1": "1:5.41-3ubuntu0.1",
            "libmagic-mgc": "1:5.41-3ubuntu0.1"
        }
    ]
}