USN-6369-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6369-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6369-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6369-2
Related
Published
2023-09-28T03:20:17.499088Z
Modified
2023-09-28T03:20:17.499088Z
Summary
libwebp vulnerability
Details

USN-6369-1 fixed a vulnerability in libwebp. This update provides the corresponding update for Ubuntu 18.04 LTS.

Original advisory details:

It was discovered that libwebp incorrectly handled certain malformed images. If a user or automated system were tricked into opening a specially crafted image file, a remote attacker could use this issue to cause libwebp to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:Pro:18.04:LTS / libwebp

Package

Name
libwebp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.1-2ubuntu0.18.04.2+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libwebpdemux2": "0.6.1-2ubuntu0.18.04.2+esm1",
            "libwebp6": "0.6.1-2ubuntu0.18.04.2+esm1",
            "webp": "0.6.1-2ubuntu0.18.04.2+esm1",
            "libwebpmux3": "0.6.1-2ubuntu0.18.04.2+esm1",
            "libwebp-dev": "0.6.1-2ubuntu0.18.04.2+esm1"
        }
    ]
}