USN-6622-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6622-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6622-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6622-1
Related
Published
2024-02-05T12:18:56.110746Z
Modified
2024-02-05T12:18:56.110746Z
Summary
openssl vulnerabilities
Details

David Benjamin discovered that OpenSSL incorrectly handled excessively long X9.42 DH keys. A remote attacker could possibly use this issue to cause OpenSSL to consume resources, leading to a denial of service. (CVE-2023-5678)

Sverker Eriksson discovered that OpenSSL incorrectly handled POLY1304 MAC on the PowerPC architecture. A remote attacker could use this issue to cause OpenSSL to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 22.04 LTS and Ubuntu 23.04. (CVE-2023-6129)

It was discovered that OpenSSL incorrectly handled excessively long RSA public keys. A remote attacker could possibly use this issue to cause OpenSSL to consume resources, leading to a denial of service. This issue only affected Ubuntu 22.04 LTS and Ubuntu 23.04. (CVE-2023-6237)

Bahaa Naamneh discovered that OpenSSL incorrectly handled certain malformed PKCS12 files. A remote attacker could possibly use this issue to cause OpenSSL to crash, resulting in a denial of service. (CVE-2024-0727)

References

Affected packages

Ubuntu:20.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.1f-1ubuntu2.21

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl-dev": "1.1.1f-1ubuntu2.21",
            "libssl-doc": "1.1.1f-1ubuntu2.21",
            "libssl1.1": "1.1.1f-1ubuntu2.21",
            "openssl": "1.1.1f-1ubuntu2.21"
        }
    ]
}

Ubuntu:22.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.2-0ubuntu1.14

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl3": "3.0.2-0ubuntu1.14",
            "libssl-dev": "3.0.2-0ubuntu1.14",
            "libssl-doc": "3.0.2-0ubuntu1.14",
            "openssl": "3.0.2-0ubuntu1.14"
        }
    ]
}

Ubuntu:23.10 / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.10-1ubuntu2.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssl3": "3.0.10-1ubuntu2.2",
            "libssl-dev": "3.0.10-1ubuntu2.2",
            "libssl-doc": "3.0.10-1ubuntu2.2",
            "openssl": "3.0.10-1ubuntu2.2"
        }
    ]
}