USN-6629-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6629-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6629-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6629-2
Related
Published
2024-02-14T02:58:36.940891Z
Modified
2024-02-14T02:58:36.940891Z
Summary
ujson vulnerability
Details

USN-6629-1 fixed vulnerabilities in UltraJSON. This update provides the corresponding updates for Ubuntu 20.04 LTS.

Original advisory details:

It was discovered that UltraJSON incorrectly handled certain input with a large amount of indentation. An attacker could possibly use this issue to crash the program, resulting in a denial of service. (CVE-2021-45958)

Jake Miller discovered that UltraJSON incorrectly decoded certain characters. An attacker could possibly use this issue to cause key confusion and overwrite values in dictionaries. (CVE-2022-31116)

It was discovered that UltraJSON incorrectly handled an error when reallocating a buffer for string decoding. An attacker could possibly use this issue to corrupt memory. (CVE-2022-31117)

References

Affected packages

Ubuntu:20.04:LTS / ujson

Package

Name
ujson

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.35-4ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-ujson": "1.35-4ubuntu0.1"
        }
    ]
}