USN-6641-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6641-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6641-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6641-1
Related
Published
2024-02-19T08:44:03.359900Z
Modified
2024-02-19T08:44:03.359900Z
Summary
curl vulnerability
Details

Harry Sintonen discovered that curl incorrectly handled mixed case cookie domains. A remote attacker could possibly use this issue to set cookies that get sent to different and unrelated sites and domains.

References

Affected packages

Ubuntu:Pro:18.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.58.0-2ubuntu3.24+esm3

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "curl": "7.58.0-2ubuntu3.24+esm3",
            "libcurl4": "7.58.0-2ubuntu3.24+esm3",
            "libcurl4-gnutls-dev": "7.58.0-2ubuntu3.24+esm3",
            "libcurl3-gnutls": "7.58.0-2ubuntu3.24+esm3",
            "libcurl4-doc": "7.58.0-2ubuntu3.24+esm3",
            "libcurl3-nss": "7.58.0-2ubuntu3.24+esm3",
            "libcurl4-nss-dev": "7.58.0-2ubuntu3.24+esm3",
            "libcurl4-openssl-dev": "7.58.0-2ubuntu3.24+esm3"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.47.0-1ubuntu2.19+esm11

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "curl": "7.47.0-1ubuntu2.19+esm11",
            "libcurl3": "7.47.0-1ubuntu2.19+esm11",
            "libcurl4-gnutls-dev": "7.47.0-1ubuntu2.19+esm11",
            "libcurl3-gnutls": "7.47.0-1ubuntu2.19+esm11",
            "libcurl4-doc": "7.47.0-1ubuntu2.19+esm11",
            "libcurl3-nss": "7.47.0-1ubuntu2.19+esm11",
            "libcurl4-nss-dev": "7.47.0-1ubuntu2.19+esm11",
            "libcurl4-openssl-dev": "7.47.0-1ubuntu2.19+esm11"
        }
    ]
}