USN-6663-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6663-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6663-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6663-2
Published
2024-03-13T08:04:31.695993Z
Modified
2024-03-13T08:04:31.695993Z
Summary
openssl update
Details

USN-6663-1 provided a security update for OpenSSL. This update provides the corresponding update for Ubuntu 16.04 LTS.

Original advisory details:

As a security improvement, this update prevents OpenSSL from returning an error when detecting wrong padding in PKCS#1 v1.5 RSA, to prevent its use in possible Bleichenbacher timing attacks.

References

Affected packages

Ubuntu:Pro:16.04:LTS / openssl

Package

Name
openssl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.2g-1ubuntu4.20+esm12

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libssl-dev": "1.0.2g-1ubuntu4.20+esm12",
            "libssl-doc": "1.0.2g-1ubuntu4.20+esm12",
            "openssl": "1.0.2g-1ubuntu4.20+esm12",
            "libssl1.0.0": "1.0.2g-1ubuntu4.20+esm12"
        }
    ]
}