USN-6731-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6731-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6731-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6731-1
Related
Published
2024-04-15T10:27:32.567052Z
Modified
2024-04-15T10:27:32.567052Z
Summary
yard vulnerabilities
Details

It was discovered that YARD before 0.9.11 does not block relative paths with an initial ../ sequence, which allows attackers to conduct directory traversal attacks and read arbitrary files. This issue only affected Ubuntu 16.04 LTS. (CVE-2017-17042)

It was discovered that yard before 0.9.20 is affected by a path traversal vulnerability, allowing HTTP requests to access arbitrary files under certain conditions. This issue only affected Ubuntu 18.04 LTS. (CVE-2019-1020001)

Aviv Keller discovered that the "frames.html" file within the Yard Doc's generated documentation is vulnerable to Cross-Site Scripting (XSS) attacks due to inadequate sanitization of user input within the JavaScript segment of the "frames.erb" template file. (CVE-2024-27285)

References

Affected packages

Ubuntu:Pro:18.04:LTS / yard

Package

Name
yard

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.9.12-2ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "yard": "0.9.12-2ubuntu0.1~esm1",
            "yard-doc": "0.9.12-2ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:20.04:LTS / yard

Package

Name
yard

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.9.24-1+deb11u1build0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "yard": "0.9.24-1+deb11u1build0.20.04.1",
            "yard-doc": "0.9.24-1+deb11u1build0.20.04.1"
        }
    ]
}

Ubuntu:22.04:LTS / yard

Package

Name
yard

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.9.26-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "yard": "0.9.26-1ubuntu0.1",
            "yard-doc": "0.9.26-1ubuntu0.1"
        }
    ]
}

Ubuntu:23.10 / yard

Package

Name
yard

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.9.28-2ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "yard": "0.9.28-2ubuntu0.1",
            "yard-doc": "0.9.28-2ubuntu0.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / yard

Package

Name
yard

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.8.7.6+git20160220-3ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "yard": "0.8.7.6+git20160220-3ubuntu0.1~esm1",
            "yard-doc": "0.8.7.6+git20160220-3ubuntu0.1~esm1"
        }
    ]
}