ALPINE-CVE-2024-35164

Source
https://security.alpinelinux.org/vuln/CVE-2024-35164
Import Source
https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2024-35164.json
JSON Data
https://api.osv.dev/v1/vulns/ALPINE-CVE-2024-35164
Upstream
Published
2025-07-02T12:15:27Z
Modified
2026-11-03T06:32:07Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process.

Users are recommended to upgrade to version 1.6.0, which fixes this issue.

References

Affected packages

Alpine:v3.23 / guacamole-server

Package

Name
guacamole-server
Purl
pkg:apk/alpine/guacamole-server?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected
Fixed
1.6.0-r0

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2024-35164.json"

Alpine:v3.24 / guacamole-server

Package

Name
guacamole-server
Purl
pkg:apk/alpine/guacamole-server?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected
Fixed
1.6.0-r0

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2024-35164.json"