ALPINE-CVE-2025-69262

Source
https://security.alpinelinux.org/vuln/CVE-2025-69262
Import Source
https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2025-69262.json
JSON Data
https://api.osv.dev/v1/vulns/ALPINE-CVE-2025-69262
Upstream
Published
2026-01-07T23:15:50Z
Modified
2026-11-03T06:33:01Z
Severity
  • 7.8 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

References

Affected packages

Alpine:v3.23 / pnpm

Package

Name
pnpm
Purl
pkg:apk/alpine/pnpm?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.25.0
Fixed
10.33.4-r0

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2025-69262.json"