ALPINE-CVE-2026-40176

Source
https://security.alpinelinux.org/vuln/CVE-2026-40176
Import Source
https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-40176.json
JSON Data
https://api.osv.dev/v1/vulns/ALPINE-CVE-2026-40176
Upstream
Published
2026-04-15T21:17:27Z
Modified
2026-11-03T06:33:02Z
Severity
  • 7.8 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shell commands by interpolating user-supplied Perforce connection parameters (port, user, client) without proper escaping. An attacker can inject arbitrary commands through these values in a malicious composer.json declaring a Perforce VCS repository, leading to command execution in the context of the user running Composer, even if Perforce is not installed. VCS repositories are only loaded from the root composer.json or the composer config directory, so this cannot be exploited through composer.json files of packages installed as dependencies. Users are at risk if they run Composer commands on untrusted projects with attacker-supplied composer.json files. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline).

References

Affected packages

Alpine:v3.23 / composer

Package

Name
composer
Purl
pkg:apk/alpine/composer?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0.0
Fixed
2.9.6-r0

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-40176.json"

Alpine:v3.24 / composer

Package

Name
composer
Purl
pkg:apk/alpine/composer?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0.0
Fixed
2.9.6-r0

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-40176.json"