ALPINE-CVE-2026-42258

Source
https://security.alpinelinux.org/vuln/CVE-2026-42258
Import Source
https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-42258.json
JSON Data
https://api.osv.dev/v1/vulns/ALPINE-CVE-2026-42258
Upstream
Published
2026-05-09T20:16:28Z
Modified
2026-10-27T12:30:04Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:L CVSS Calculator
Summary
[none]
Details

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, symbol arguments to commands are vulnerable to a CRLF Injection / IMAP Command injection via Symbol arguments passed to IMAP commands. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.

References

Affected packages

Alpine:v3.21 / ruby-net-imap

Package

Name
ruby-net-imap
Purl
pkg:apk/alpine/ruby-net-imap?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected
Fixed
0.4.25-r0

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-42258.json"