ALSA-2024:0533

Import Source
https://github.com/AlmaLinux/osv-database/blob/master/advisories/almalinux9/ALSA-2024:0533.json
Related
Published
2024-01-29T00:00:00Z
Modified
2024-01-29T16:57:50Z
Details

The gnutls packages provide the GNU Transport Layer Security (GnuTLS) library, which implements cryptographic algorithms and protocols such as SSL, TLS, and DTLS.

Security Fix(es):

  • gnutls: timing side-channel in the RSA-PSK authentication (CVE-2023-5981)
  • gnutls: incomplete fix for CVE-2023-5981 (CVE-2024-0553)
  • gnutls: rejects certificate chain with distributed trust (CVE-2024-0567)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Affected packages

AlmaLinux:9 / gnutls

Package

Name
gnutls

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
3.7.6-23.el9_3.3

AlmaLinux:9 / gnutls-c++

Package

Name
gnutls-c++

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
3.7.6-23.el9_3.3

AlmaLinux:9 / gnutls-dane

Package

Name
gnutls-dane

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
3.7.6-23.el9_3.3

AlmaLinux:9 / gnutls-devel

Package

Name
gnutls-devel

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
3.7.6-23.el9_3.3

AlmaLinux:9 / gnutls-utils

Package

Name
gnutls-utils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
3.7.6-23.el9_3.3