ALSA-2024:1435

Source
https://errata.almalinux.org/8/ALSA-2024-1435.html
Import Source
https://github.com/AlmaLinux/osv-database/blob/master/advisories/almalinux8/ALSA-2024:1435.json
Related
Published
2024-03-20T00:00:00Z
Modified
2024-03-21T08:51:52Z
Details

PostgreSQL is an advanced object-relational database management system. The postgresql-jdbc package includes the .jar files needed for Java programs to access a PostgreSQL database.

Security Fix(es):

  • PostgreSQL JDBC Driver allows attacker to inject SQL if using PreferQueryMode=SIMPLE (CVE-2024-1597)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Affected packages

AlmaLinux:8 / postgresql-jdbc

Package

Name
postgresql-jdbc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
42.2.14-3.el8_9

AlmaLinux:8 / postgresql-jdbc-javadoc

Package

Name
postgresql-jdbc-javadoc

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
42.2.14-3.el8_9