ALSA-2024:3340

See a problem?
Source
https://errata.almalinux.org/8/ALSA-2024-3340.html
Import Source
https://github.com/AlmaLinux/osv-database/blob/master/advisories/almalinux8/ALSA-2024:3340.json
JSON Data
https://api.osv.dev/v1/vulns/ALSA-2024:3340
Related
  • CVE-2024-30045
  • CVE-2024-30046
Published
2024-05-23T00:00:00Z
Modified
2024-05-29T14:45:35Z
Summary
Important: .NET 7.0 security update
Details

.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation.

New versions of .NET that address a security vulnerability are now available. The updated versions are .NET SDK 7.0.119 and .NET Runtime 7.0.19.

Security Fix(es):

  • dotnet: stack buffer overrun in Double Parse (CVE-2024-30045)
  • dotnet: denial of service in ASP.NET Core due to deadlock in Http2OutputProducer.Stop() (CVE-2024-30046)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Affected packages

AlmaLinux:8 / aspnetcore-runtime-7.0

Package

Name
aspnetcore-runtime-7.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.19-1.el8_10

AlmaLinux:8 / aspnetcore-targeting-pack-7.0

Package

Name
aspnetcore-targeting-pack-7.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.19-1.el8_10

AlmaLinux:8 / dotnet-apphost-pack-7.0

Package

Name
dotnet-apphost-pack-7.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.19-1.el8_10

AlmaLinux:8 / dotnet-hostfxr-7.0

Package

Name
dotnet-hostfxr-7.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.19-1.el8_10

AlmaLinux:8 / dotnet-runtime-7.0

Package

Name
dotnet-runtime-7.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.19-1.el8_10

AlmaLinux:8 / dotnet-sdk-7.0

Package

Name
dotnet-sdk-7.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.119-1.el8_10

AlmaLinux:8 / dotnet-sdk-7.0-source-built-artifacts

Package

Name
dotnet-sdk-7.0-source-built-artifacts

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.119-1.el8_10

AlmaLinux:8 / dotnet-targeting-pack-7.0

Package

Name
dotnet-targeting-pack-7.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.19-1.el8_10

AlmaLinux:8 / dotnet-templates-7.0

Package

Name
dotnet-templates-7.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.119-1.el8_10