ALSA-2024:3343

See a problem?
Source
https://errata.almalinux.org/8/ALSA-2024-3343.html
Import Source
https://github.com/AlmaLinux/osv-database/blob/master/advisories/almalinux8/ALSA-2024:3343.json
JSON Data
https://api.osv.dev/v1/vulns/ALSA-2024:3343
Related
  • CVE-2024-31080
  • CVE-2024-31081
  • CVE-2024-31083
Published
2024-05-23T00:00:00Z
Modified
2024-05-29T14:39:47Z
Summary
Important: xorg-x11-server-Xwayland security update
Details

Xwayland is an X server for running X clients under Wayland.

Security Fix(es):

  • xorg-x11-server: Heap buffer overread/data leakage in ProcXIGetSelectedEvents (CVE-2024-31080)
  • xorg-x11-server: Heap buffer overread/data leakage in ProcXIPassiveGrabDevice (CVE-2024-31081)
  • xorg-x11-server: Use-after-free in ProcRenderAddGlyphs (CVE-2024-31083)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Affected packages

AlmaLinux:8 / xorg-x11-server-Xwayland

Package

Name
xorg-x11-server-Xwayland

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
21.1.3-16.el8_10